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Read Me First 
Welcome to Take Control of Getting Started with DEVONthink 2, 
Third Edition, version 3.0, published in November 2016 by TidBITS 
Publishing Inc. This book was written by Joe Kissell and edited by 
Tonya Engst, with significant help from Kelly Turner. 

This book teaches you the basics of DEVONthink (Personal, Profes-
sional, and Pro Office editions) version 2 on the Mac and DEVONthink 
To Go in iOS. You’ll learn how to find your way around, get informa-
tion into and out of DEVONthink, and make the most of the program’s 
most important features. 

Copyright © 2016, alt concepts inc. All rights reserved. 

Sponsored by DEVONtechnologies 
This book was sponsored by DEVONtechnologies. Special thanks to
 

Eric Böhnisch-Volkmann for his enthusiasm for the project and to
 

Christian Grunenberg for his clarifications about subtle features.
 

Updates and More
 

You can access extras related to this ebook on the Web (use the link 
in Ebook Extras, near the end; it’s available only to purchasers). On 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. 
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If you bought this ebook from the Take Control Web site, it has been 
added to your account, where you can download it in other formats 
and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually; see Ebook Extras. 

Basics
 

To review background information that might help you understand 
this book better, such as finding System Preferences and working with 
files in the Finder, read Tonya Engst’s free ebook Read Me First: A 
Take Control Crash Course, available for free on the Web or as a 
standalone ebook in PDF, EPUB, and the Kindle’s Mobipocket format. 

What’s New in the Third Edition
 

DEVONthink has been updated quite a few times since I wrote the 
second edition of this book (back when version 2.3.3 was current). 
Even though the software is still “DEVONthink 2” (that is, version 2.x), 
the latest version as I write this text—version 2.9.6—includes hundreds 
of (mostly minor) changes and bug fixes compared to what I described 
earlier, as well as some significant new features. In addition, since the 
second edition appeared, Apple released several major upgrades to the 
Mac operating system, each of which had its own long list of changes. 

Accordingly, I’ve updated this book in many ways, both large and 
small. 

Tip: If you already read the second edition of this book, take a glance 
at Quicker Start for Second Edition Readers! 

Among the most significant changes are the following: 

•	 Updated the page Quicker Start for Second Edition Readers to help 
readers of the previous edition find new information quickly 

4
 

Click here to buy the full 217-page “Take Control of Getting Started with DEVONthink 2” for only $15!

http://www.takecontrolbooks.com/resources/0167/site/chap01.html
http://www.takecontrolbooks.com/resources/0167/site/chap01.html
https://www.takecontrolbooks.com/cart?add-to-cart=1097


        
            

          
   

      
   

           

       
   

        
     

         
       

 

         
        

         
       

     

      

     

             

•	 Revised the sidebar Where Not to Store Your Databases to reflect 
the new sync capabilities, and to mention that iCloud Drive isn’t a 
good place for your databases 

•	 Added a number of newer options to Create Documents in DEVON-
think, including Formatted Note, HTML Page, and Markdown Text 

•	 Thoroughly revised Clip to DEVONthink Browser Extension to 
describe its current behavior 

•	 Added instructions to Use the Share Extension for getting data into 
DEVONthink 

•	 Revised Scan Documents with up-to-date instructions for using 
ScanSnap Manager or ExactScan 

•	 Added the topic Convert Document Formats about converting docu-
ments from one format to another 

•	 Rewrote nearly all of the Sync Your DEVONthink Databases 
chapter, which now covers DEVONthink’s new (and vastly im-
proved) sync capability 

•	 Rewrote the entire Use DEVONthink To Go chapter, which now 
covers the completely rewritten DEVONthink To Go version 2 

•	 In the Get Information Out of DEVONthink chapter, significantly 
updated the topics Use DEVONthink’s Web Server and Export Data, 
and added the topic Share Data 

•	 Revised much of Use AppleScript and Automator with DEVONthink 

•	 Replaced all the graphics with up-to-date versions 

•	 Modernized the look and feel of the book to reflect the latest Take 
Control style 
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Introduction 
I almost don’t know where to begin. That’s my problem as an author, 
and it may be your problem as a user, too. DEVONthink is an informa-
tion management tool with a marvelously deep, rich set of features, 
and it can adapt itself to just about any set of needs or work prefer-
ences. That’s the good news; the bad news is that this wealth of power 
is like a 50-page restaurant menu in which every dish sounds equally 
delicious. There are so many excellent choices that finding a clear 
strategy to make the most of the meal—or the software, as the case may 
be—can be a daunting prospect. 

My goal in this book is to do just that: to help you wrap your brain 
around DEVONthink’s extensive options and figure out how best to 
use it to accomplish your goals. Whether you are starting out with the 
program for the first time or are a seasoned user looking for ways to 
get more out of it, I hope to show you where to focus, what to try, and 
how to think about DEVONthink in the most effective way. 

DEVONthink already has plenty of good documentation in the form of 
built-in help files (also available as a stand-alone ebook). The purpose 
of this book is neither to replace that information nor to explain the 
operation of every command and button. Rather than create an ex-
haustive reference, I concentrate on the key tasks you’ll want to accom-
plish. (That’s why we put “Getting Started with…” in the title!) After 
providing an overview of the program’s main concepts and interface, 
I walk you through the principal activities you’ll do over and over, such 
as getting information into DEVONthink; organizing, finding, and 
working with that information within the program; and, finally, getting 
the information back out, by exporting or sharing it. 

And if all that leaves you hungry for more, I also provide a bit of 
dessert—a chapter that goes a bit deeper into some of the program’s 
advanced capabilities. 
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Stepping Stones 
I’ve peppered this book with a series of “Stepping Stones” sidebars 
like this one, which provide special advice for working through com-
plex choices in DEVONthink. Think of them as stepping stones that 
help you navigate both the book and the software more easily. 

Note: DEVONthink comes in Personal, Professional, and Pro Office 
editions (see DEVONthink Editions for details). When I write “DEVON-
think,” I’m referring to features in all three; where appropriate, I 
mention which edition(s) are missing any features I discuss. 

Since the second edition of this book was published, DEVONthink has 
had six major updates, and DEVONtechnologies is constantly working 
on improving the software. As a result, since the time I wrote this third 
edition (published when DEVONthink version 2.9.6 was current, and 
the new sync capability had only recently appeared), any number of 
things may have changed—new features may have been added, bugs 
fixed, interface elements rearranged, and so on. 

Unfortunately, we can’t update this book as frequently as the software, 
so you may occasionally encounter something in the book that doesn’t 
quite match with what you see on your screen. I don’t expect these 
small inconsistencies to cause you any problems, but I do recommend 
reading the release notes for each update of DEVONthink you install 
for details on what’s new. And be sure to access the online Ebook 
Extras for this ebook in order to check the blog from time to time to 
see if I’ve added any new information. 
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DEVONthink Quick Start 
This book helps you find your way around DEVONthink and use its 
most important features effectively. Each chapter builds on the one 
before it, so I recommend reading the book sequentially. If you choose 
to jump around, please read at least the first two chapters— 
Understand DEVONthink Basics and Explore DEVONthink’s 
Interface—which will help you understand the rest of the material. 

Get your bearings: 
•	 If you’ve already spent time with the second edition of this ebook, 

read Quicker Start for Second Edition Readers, ahead shortly. 

•	 Acquaint yourself with DEVONthink’s unique conventions and 
terminology; see Understand DEVONthink Basics. 

•	 Learn your way around and find essential features; see Explore 
DEVONthink’s Interface. 

•	 Create one or more containers to hold your personal data; see Set 
Up DEVONthink Databases. 

Put DEVONthink to work: 
•	 Create new documents or import data from a variety of sources; see 

Get Information into DEVONthink. 

•	 Group, label, and tag data; see Organize Your Information. 

•	 Use simple or advanced techniques to locate data you’ve previously 
stored in DEVONthink; see Find Your Information. 

•	 Edit data in DEVONthink or an external editor, and use OCR with 
scanned documents; see Work with Your Information. 

•	 Store and manage your DEVONthink data on any iOS device; see 
Use DEVONthink To Go. 
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Share and sync your DEVONthink data:
 
•	 If you want to share data with other people, consider your options 

in the sidebar Choosing a Sharing Strategy. 

•	 Keep multiple copies of DEVONthink in sync; see Sync Your 
DEVONthink Databases. 

•	 Share data over the Web or export it in numerous formats; see Get 
Information Out of DEVONthink. 

Go beyond the basics: 
•	 Solve problems and learn about some advanced features; see Dig 

Deeper. 

•	 Find a list of keyboard (and keyboard-plus-mouse) shortcuts; see 
Appendix A: Keyboard Shortcuts. 

•	 Find resources for further exploration; see Learn More. 

9
 

Click here to buy the full 217-page “Take Control of Getting Started with DEVONthink 2” for only $15!

https://www.takecontrolbooks.com/cart?add-to-cart=1097


 

        
            

             
            

              
           

                
       

                
           

             
   

        
           
          

        
         

  

Quicker Start for Second 
Edition Readers 

Although much has changed in DEVONthink and macOS over the past 
couple of years, anyone who already read the second edition of this 
book should have a good grasp of the fundamentals and won’t need to 
re-read this entire edition—or even all the items listed in What’s New 
in the Third Edition, a few pages back. It will, however, be a more 
valuable reference guide since it now more closely matches reality, so 
the next time you dip into a feature you haven’t tried in a while, be sure 
to consult the relevant portion of the book. 

If it’s been a long time since you first read this book, or if you haven’t 
paid careful attention to all the recent changes in DEVONthink and 
macOS, I want to draw your attention to two items in particular that 
are well worth a fresh look: 

•	 Although DEVONthink previously offered a sync capability, it had 
a lot of problems. The syncing code has been replaced entirely with 
a modern, fast, and flexible system. See Sync Your DEVONthink 
Databases. 

•	 DEVONthink’s iOS app, DEVONthink To Go, has also been 
rewritten from scratch and is now massively more useful. See Use 
DEVONthink To Go. 
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Understand DEVONthink 
Basics 

DEVONthink isn’t difficult to use, but because it offers unique ways of 
dealing with your data, it requires you to learn a few new concepts and 
terms, and understand some behaviors that may be unexpected at first. 

Once you have a grip on the basic principles that underlie DEVON-
think’s operation, you’ll find that its other features and capabilities fall 
into place more readily. Meanwhile, even though DEVONthink is both 
powerful and versatile, it’s not always the right tool for the job—so it’s 
also important to understand What DEVONthink Is Not Good For. 

What Exactly Is DEVONthink?
 

Because you’re reading this book, I assume you already have a copy of 
DEVONthink, and that in turn implies that you have at least some idea 
what it is. But as I discovered when surveying a variety of DEVONthink 
users, different people think of the program in very different ways. 
There’s no one right answer, but as you get to know DEVONthink, it 
may be helpful to understand what it is (and isn’t), how it can function, 
and how it differs from other comparable software. 

Among the many hats DEVONthink can wear are the following: 

•	 File and media browser: Like the Finder, DEVONthink can 
organize files in a hierarchical folder structure. And like iTunes and 
Photos, it can also store and play media such as music, photos, and 
videos (although its media capabilities are less advanced than those 
in iTunes and Photos). In addition, it stores metadata, extra pieces 
of information about each item (such as labels and modification 
date) in a special database, separate from the files themselves. 
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Everything you put into DEVONthink is indexed for fast searching 
and sorting, and you can group and identify information in ways the 
Finder doesn’t offer. All the original files are still available in their 
raw states on your disk, but from within DEVONthink you can see 
and use your data in much more flexible ways. 

•	 Snippet keeper: In the course of a day, you may want to keep 
track of URLs, notes to yourself, parts of Web pages, screenshots, 
and countless other bits of information that don’t necessarily fit the 
mold of stand-alone files. Any app that provides a convenient way to 
capture and store such a wide variety of data can be called a snippet 
keeper. Apps such as EagleFiler, Evernote, MacJournal, SOHO 
Notes, Tinderbox, Together, and Yojimbo—not to mention the 
Mac’s built-in Notes app—fall into this category. DEVONthink, too, 
can function as an outstanding snippet keeper, thanks to its remark-
able capability to manage miscellaneous data. 

•	 Note taker: For people who spend a lot of time in classes or meet-
ings, another popular category of tool is the note taker. With apps 
such as Curio, NoteTaker, Microsoft OneNote, and Useful Fruit 
Software’s Pear Note, you can not only type notes (as you could in 
any word processor or snippet keeper) but also record audio, high-
light and annotate text, make outlines, and do similar sorts of note-
taking tasks. DEVONthink, too, offers several ways to facilitate 
note-taking (although currently, only DEVONthink To Go supports 
audio recording; the desktop versions do not). 

•	 Database: Database applications, such as FileMaker Pro, 
Panorama, and 4D, are in some senses the opposite of free-form 
note-taking programs. By imposing a carefully designed structure 
on your data—whether it be a list of wine bottles in your basement, 
data on your company’s customers (or patients or clients), or an 
online catalog of thousands of products—databases enable you 
to filter and find data with great precision and flexibility. DEVON-
think, too, is a database of sorts, and although it doesn’t have all the 
capabilities of stand-alone databases, it does let you slice and dice 
some kinds of information in much the same way. 
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Explore DEVONthink’s 
Interface 

Now that you know the basic concepts and terms that DEVONthink 
uses, it’s time to learn your way around. Because of the many ways 
DEVONthink can display your data and some of the unique tools it 
offers, you’ll be on a firmer footing if you take a few moments to read 
this chapter and learn how the interface is organized, where to find the 
things that you’ll use most often, and what some of the program’s icons 
and other controls do. 

Support Assistant
 

The first time you launch DEVONthink, a window called the Support 
Assistant opens (Figure 1) to welcome you and offer tips, tutorials, 
support, and other help. 

Figure 1: The Support Assistant welcomes you with tips and 
tutorials. 
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The Support Assistant window will appear every time you launch 
DEVONthink. To keep it from doing so, deselect the Show This Win-
dow When DEVONthink Opens checkbox. (You can then display it 
manually, whenever you want, by choosing Help > Support Assistant.) 

Although it may not be obvious at first glance, you can access lots of 
useful features from the Welcome screen of this window: 

•	 Intro screencast: Click Click to Play to see a movie demonstrat-
ing some of DEVONthink’s key features. 

•	 Newsletter subscription: To subscribe to a free periodic news-
letter with DEVONthink tips, enter your email address under 
“Newsletter.” Then click the green checkmark icon to subscribe. 

•	 Tip and extra of the day: The right side of the Welcome screen 
presents a random selection from the tips and extras, all of which 
are found elsewhere in the Support Assistant. 

•	 Technical support: Click the Get Support link at the bottom 
of the window for shortcuts to the DEVONthink FAQ, user forum, 
and contact page, plus tools to retrieve a lost license, extend a trial 
license, update your email address, and purchase an upgrade. (As 
with the newsletter subscription, if your email address is incorrect, 
you can triple-click it and type a new one before clicking the green 
checkmark icon.) 

•	 Extras: Click the Install Extras link at the bottom of the window 
to display a screen with extra AppleScripts and templates (beyond 
those installed automatically, as discussed in Included Scripts and 
Template); you can install any of these with one click by clicking 
the Install button beneath it. (To remove an installed item, click 
Remove.) 

•	 Tips and tutorials: Click the Tips & Tutorials link at the bottom 
of the window to show a selection of text-based tips (at the top) and 
step-by-step illustrated tutorials (at the bottom). 

Tip: To return to the top Welcome screen of the Support Assistant at 
any time, click the Welcome link at the bottom of the window. 
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Set Up DEVONthink 
Databases 

Now that you know your way around DEVONthink, it’s time to create 
one or more databases and start collecting information. You can set up 
a database with just a few clicks, but you may also want to customize 
(and even password-protect) your database. 

Create a New Database
 

DEVONthink Personal automatically creates its database (it supports 
only one) when you first launch it. DEVONthink Professional and 
DEVONthink Pro Office prompt you to create a database when you 
open them for the first time, and for many people that single database 
is sufficient. But if you want to create an additional database, the 
process is simple: 

1.	 Choose File > New Database. A file dialog appears. 

2.	 Enter a name for your database and choose a location (or accept the 
default location). If you’re tempted to choose your Dropbox, any 
iCloud Drive location, or a local network server as your destination, 
please read the sidebar just ahead, Where Not to Store Your Data-
bases, first! 

3.	 If you want to keep the information in your DEVONthink database 
from being indexed by Spotlight, uncheck Create Spotlight Index. 
Doing so doesn’t prevent you from searching within DEVONthink, 
but it does prevent the contents of the database from appearing in 
system-wide Spotlight searches. (Choose this option if your data-
base contains sensitive data and you’re concerned that someone else 
with access to your Mac might stumble on it while using Spotlight.) 

4.	 Click Create. 

DEVONthink creates a new, empty database. 
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Where Not to Store Your Databases 
You can save your DEVONthink database(s) anywhere you like on an 
internal or external disk or SSD—somewhere inside your ~/Documents 
folder is probably a good choice for most people. But you may be 
tempted to store your databases in certain locations where you 
probably shouldn’t: Dropbox, iCloud Drive, and network servers. I 
hasten to point out that this isn’t a prohibition, but I strongly recom-
mend against these destinations. Here’s why. 

Because of the way DEVONthink stores data and the way Dropbox 
and iCloud Drive syncing work, if you should open the same database 
on two Macs (or a Mac and an iOS device) at the same time (or if you 
open it on a second device after closing it on the first one, but before 
the sync has completed), you can lose data. Dropbox and iCloud 
Drive will blindly overwrite older data with newer data, and have no 
way to sync individual data elements within your database. If you’re 
very careful, you can avoid this—but in my opinion, the risk is too 
great to chance it. (But, take heart! You can still sync your data with 
other devices using Dropbox or iCloud Drive; you just have to set 
that up from within DEVONthink. See Sync Locations, especially the 
sidebar Syncing with Dropbox.) 

So, what about a server on your local network, such as another Mac 
that uses the Mac’s built-in file sharing? You face a similar danger, 
in that two Macs accessing a single database at the same time can 
cause data loss. You won’t have to worry about syncing delays, but 
on the other hand, you may encounter slowdowns in saving your 
work as you use DEVONthink. A better solution, again, is to sync your 
local data to the server—see Sync Locations. 

54
 

Click here to buy the full 217-page “Take Control of Getting Started with DEVONthink 2” for only $15!

https://www.takecontrolbooks.com/cart?add-to-cart=1097


 

        
         

          
            

       

             
           

          
            

         
         

     

            
           

             
           

     

           
             

      

      
          

        
          

      
     

Get Information into 
DEVONthink 

Whether you’re starting from scratch with newly created data or 
importing content from existing files or Internet sources, DEVONthink 
offers many mechanisms for collecting information. In fact, the biggest 
problem you may have is deciding which method you should use to put 
a particular piece of information into your database. 

In this chapter, I begin by discussing what you can put in DEVONthink 
and helping you figure out where you want DEVONthink to place 
newly added content by default. With this important decision out of 
the way, I then explain the major ways of adding data. I finish with 
Joe’s Recommendations for Getting Stuff into DEVONthink, a topic 
aimed at helping you come to grips with all the choices. 

What Can I Put in DEVONthink?
 

In case you’re wondering what kinds of documents you can put in 
DEVONthink, the answer is any kind at all! DEVONthink can index 
anything containing text, and it can display nearly any kind of text or 
graphics file, most audio and video files, and even documents from 
Microsoft Office and Apple’s iWork apps. 

Even if you import a document that DEVONthink can’t display, the 
document can stay in the database, and you can open it using another 
program (see Edit Documents in External Applications). 

Note: To prevent DEVONthink from importing certain kinds of files 
when you use File > Import or drag and drop (for example, you may 
want to keep all music out of DEVONthink, even if there happens to 
be a music file in a folder you import), choose Preferences > 
Import > Files and uncheck the relevant boxes in the Files section. 
Individual files you import manually override these settings. 
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Decide Where Your Documents Will Go
 

As you use DEVONthink, you can put each document in a specific 
group, in a catch-all inbox—perhaps in any of several databases—or 
in the global Inbox. For the most part, you get to choose where docu-
ments go, although there are cases in which you may not have realized 
what your choice was, so the result may be confusing if you’re not 
familiar with DEVONthink’s system. 

The general rule (to which there are a few exceptions) is that docu-
ments go in either of two places: 

• Where you put them 

• A default destination, which you can choose (within limits) 

When you create a new document from within DEVONthink—and that 
includes importing or indexing documents using the File > Import or 
File > Index command—it goes in the currently selected or open group 
or tag; if nothing is selected or open, it goes to the top of the selected 
database. In other words, documents created from within DEVON-
think are always in the “where you put them” category. 

Likewise, if you drag a document, text clipping, email message, or 
anything else from the Finder or another application into the DEVON-
think window, it goes where you drop it—into a particular group, an 
inbox, or the top level of the database, as the case may be. Once again: 
it goes where you put it. 

However, if you start from outside DEVONthink—for example, when 
scanning a paper document, dropping a file on DEVONthink’s Dock 
icon, using the Services menu (see Use the Services Menu), or using 
a bookmarklet (see Web Bookmarklets)—the imported document goes 
to your default destination for importing data. 
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Organize Your Information 
Once you’ve gotten into the habit of collecting data in DEVONthink, 
you may quickly discover that you have hundreds or even thousands 
of pieces of information. Although you could, if you wanted, simply 
keep everything in your inbox and then search for whatever you need, 
DEVONthink offers numerous ways of grouping, labeling, tagging, and 
otherwise organizing your information. Once you’ve shown DEVON-
think how you prefer to have your information organized, you can also 
take advantage of its almost magical Auto-Classify feature. 

The better you organize your data in DEVONthink, the easier it is to 
find what you’re looking for and to see the connections between related 
items. 

Understand Groups and Tags
 

Before I tell you how to group and tag documents, I want you to know 
a bit about how the two mechanisms operate. 

Groups and tags are two ways of categorizing documents. 
Conceptually, they follow different models: you put documents in 
groups (so a document normally exists in only one location), whereas 
you apply tags to documents (so a document can have any number of 
tags). Of course, DEVONthink’s use of replicants makes it possible for 
a single document to exist in more than one location, but tags let you 
apply multiple categories to a document more simply and directly. 

Groups tend to work best for data that has a largely self-evident logical 
structure, whereas tags are generally more freeform and subjective— 
how you want to think of particular documents rather than what data 
they objectively contain. 

In order to enable groups and tags to work together as effectively as 
possible, DEVONthink uses the same underlying construct for both. 
That is to say, behind the scenes, both groups and tags are merely 
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labels—pieces of metadata associated with documents. In many re-
spects, groups and tags function (and even look) almost exactly the 
same, and you can mix and match groups and tags freely (but see the 
sidebar Stepping Stone: Are You a Grouper or a Tagger?, ahead). 

However, there are some subtle differences in behavior between 
groups and tags, and they interact in sometimes surprising ways. 

Stepping Stone: It All Makes Sense Once You Get the 
Hang of It 
I’m going to lay out some basic facts here—principles that govern 
the way tags and groups behave—but before doing so I want to 
reassure you that you need not memorize, or even understand, all 
of this in order to use groups and tags effectively! Take a couple of 
deep breaths, and try grouping or tagging a few of your example 
documents as you read through this to see these principles in action. 
And if you still feel a bit lost, skip ahead a few pages to the next 
“stepping stone” sidebar for more guidance. 

To reduce the likelihood of confusion, you should be aware of the 
following facts: 

•	 Every tag is also a group—of sorts. All your tags are listed under 
Tags at the top level of your database (in what I’m calling the Tags 
list), and if you drag a document from outside DEVONthink to one 
of these tags (meaning it’s not already in an inbox or some other 
group), the only place that document appears in your database is 
in that tag’s “group.” 

•	 Groups and tags can both be hierarchical—you can nest one inside 
another, as many levels deep as needed, just like folders in the 
Finder. You can drag and drop groups anywhere they appear in your 
database to rearrange them, but it may not be obvious how to 
rearrange tags. The easiest way to do so is to go to the Tags list at 
the top level of your database and drag one tag onto another, thus 
making the first tag a “child” of the second one. 
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Find Your Information 
One of the biggest reasons to store your stuff in DEVONthink (as 
opposed to, say, the Finder) is its fast, smart, and flexible searching. 
This chapter describes the search options, from simple to complex, 
including a look at how to Use Smart Groups. It also discusses how to 
Search Using the Concordance, a specialized way of searching based 
on the frequency with which words appear in your database. 

Perform a Simple Search
 

Most searches in DEVONthink are simple and straightforward—and 
the process couldn’t be easier. Type your search term into the search 
field on the toolbar, and DEVONthink almost instantly returns match-
ing documents from anywhere in the current database—with default 
settings, you need not even press Return (Figure 48). 

Figure 48: Type a term in the search box at the upper right for a 
super-fast search. 

Results are ranked by relevance, and each item has a colored bar that 
graphically indicates its score. Any occurrences of your search term are 
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highlighted in the results list, as well as in the documents themselves, 
(partial-word matches aren’t highlighted, however). 

Search Syntax 
Searches in DEVONthink are always case-insensitive (cat matches 
Cat and vice-versa). You can also use quotation marks to enclose 
phrases, wildcards (such as ? to match any single character and * to 
match any sequence of characters), Boolean operators (such as AND, 
OR, and NOT), parentheses to group items, and proximity terms (such 
as NEAR, BEFORE, and AFTER). Complete details about these options 
and more can be found in DEVONthink’s help. 

Refine a Search with Search Options 

If a simple search doesn’t return the results you’re looking for (or 
returns far too many results), you can click the triangle in the search 
field to display a pop-up menu with additional search options. Choose 
one of these to refine your search—and note that your choice remains 
in effect for future searches, too (even if you quit and reopen DEVON-
think), until you change it, so you may wish to reset it right after use to 
avoid future confusion. 

The first group of options, under the “Search for” label, affect where in 
each document DEVONthink searches: 

•	 All: Searches everywhere—document contents and all metadata 

•	 Content: Searches only document contents 

•	 Name: Searches only document names 

•	 URL: Searches only the URL (if any) associated with a document 

•	 Comment: Searches only the contents of the Spotlight Comments 
field (accessible in the Info Panel) 

•	 Metadata: Searches only metadata, including URLs and Com-
ments 
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Work with Your Information 
DEVONthink isn’t only about storing, organizing, and finding informa-
tion. It also contains a full set of tools for editing documents (ranging 
from plain and styled text to images) and for annotating PDFs—so you 
can do a great deal of useful work without leaving the program. And 
when you need to do editing that goes beyond DEVONthink’s capabili-
ties, you can easily open a document in the external application of your 
choice. I discuss all these options in the next several pages. 

Edit Documents in DEVONthink
 

Editing most documents is straightforward, but I must mention 
something up front that could confuse you if you aren’t expecting it: 
The fact that you can view a document in DEVONthink doesn’t neces-
sarily mean you can edit it—or, in some cases, select text in it. 

Because DEVONthink uses the Mac’s Quick Look technology, it can 
index and display any kind of media the Finder can—including graph-
ics, audio, and video files, iWork and Microsoft Office documents, and 
others for which Apple or a third party has installed an appropriate 
plugin. However, although some of these files can be manipulated 
inside DEVONthink, others cannot. The bulleted list just ahead gives 
an overview of what you can and can’t do in various kinds of docu-
ments. 

Just as when viewing documents, you can edit a document directly in 
an edit pane (for views that have them), or double-click it to open it in 
a separate window. 

Either way, before you can make changes to a document, it must be in 
a writable (as opposed to read-only) state and display an unlocked 
icon. If you see a read-only icon on the navigation bar, you must 
choose View > Text Alternative (Command-Option-P) or click the Text 

button to switch to text-only mode in order to edit the document (as 
explained in the sidebar just ahead). 
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Of course, you can’t select, edit, highlight, or annotate text in video or 
audio files. Apart from that, here are the types of editing you can do in 
which types of documents: 

•	 Select text: All document types except graphics (email messages 
must be in text-only mode—see the sidebar below) 

•	 Edit: Plain text, rich text, graphics, HTML (text-only mode), RSS 
articles (text-only mode); Word documents (.doc only, in text-only 
mode) 

• Highlight: Rich text, Web archives, and PDF only 

• Annotate: PDF only 

Preview Mode and Text-only Mode 
As noted above, certain capabilities are available only in text-only 
mode. (Oh no! Yet another way of viewing documents! Yeah, sorry.) 

DEVONthink can present the contents of certain documents either in 
its normal, WYSIWYG form (preview mode) or in a form that shows 
only the underlying text (text-only mode). You toggle between these 
views by choosing View > Text Alternative (Command-Option-P) or 
clicking a button on the navigation bar, which has one appearance in 
preview mode and another in text-only mode . What you get in 
text-only mode depends on the document type—for example: 

✦	 HTML and Web archives: HTML source 

✦ Pages documents: Plain, unstyled text 

✦ Word documents: Styled text, but no page formatting; only 
approximate paragraph formatting; and ugly, inscrutable codes 
for things like hyperlinks 

With those preliminaries out of the way, let’s look at a few of the most 
common document types you may want to edit. 
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Sync Your DEVONthink 
Databases 

If you have more than one Mac—or a Mac and one or more iOS de-
vices—you’ll probably want to use DEVONthink on each one, and that 
in turn almost certainly means you’ll want your data to stay in sync 
across your devices. We’ve all become accustomed to near-instant 
syncing of data such as email, contacts, and calendars. In addition, 
cloud services like Dropbox and iCloud Drive enable us to keep files 
and folders in sync everywhere. You can now have that same experi-
ence with your DEVONthink data. 

In the previous edition of this book, I described the sync capabilities 
DEVONthink had at that time. To put it generously, they were pretty 
weak (as in hard to configure, slow, and unreliable). But I’m delighted 
to say that DEVONtechnologies has rewritten DEVONthink’s sync 
engine from the ground up, and in my testing over the past few 
months, I’ve found it to be both speedy and dependable—a far cry from 
the earlier implementation. To use the new sync engine, you must have 
DEVONthink 2.9 or later installed. 

If you were syncing using the old DEVONthink method, you’re in for a 
treat. Yes, you’ll have to set up everything from scratch again, but it’s 
easier to do so now, and the result is quite satisfying. If you’re setting 
up syncing for the first time, there are a few things you’ll have to know, 
but after the initial setup, syncing should be nearly transparent. 

Tip: If your goal in syncing DEVONthink data between two Macs is 

less about having the data on two Macs and more about giving 

another person access to the data, see the sidebar later in this 

chapter, Choosing a Sharing Strategy, for tips on different methods 

of making your DEVONthink data available elsewhere.
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Understand Sync Basics
 

Before you jump in and set up syncing, you should be aware of the 
numerous choices DEVONthink offers and how they compare. It’s 
worth taking a few minutes to think through your options in advance 
in order to achieve your desired results. 

External vs. Built-in Syncing 
As I explained in How and Where Databases Are Stored, even though 
DEVONthink stores all your documents as individual files on disk, it 
also keeps a great deal of information in a proprietary database; the 
database and the files together are kept in a package—a folder that 
looks like a single file. Because of the way databases work, syncing is 
tricky and dangerous if you try to do it outside DEVONthink (for 
example, by using a sync app such as ChronoSync or by storing your 
database in Dropbox or a folder synced by a similar service). Making 
even a small change to a single document changes not only the corre-
sponding document file but also various parts of the database. As a 
result, if the data is synced externally while the database is open in 
more than one place, errors and data loss could occur. 

However, using DEVONthink itself to perform the syncing is another 
story altogether. DEVONthink can sync any or all of your databases 
with any number of other Macs and iOS devices, and it’s safe to make 
changes with the database open on more than one device—DEVON-
think knows how to merge your changes quickly and intelligently. 

Sync Locations 
Any database can sync to one or more locations (or none); you can 
choose whichever combination best meets your needs. Conceptually, 
the various destination choices fall into two categories—direct (a 
database syncs between two copies of DEVONthink running on differ-
ent devices) and indirect (each copy of DEVONthink syncs indepen-
dently with a sync store—a copy of the database stored in central 
location, such as a file server or cloud service). 
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Use DEVONthink To Go 
If you have an iPhone, iPad, or iPod touch, you can take your DEVON-
think data with you and work with it when you’re away from your Mac. 
To do this, you’ll need an iOS app called DEVONthink To Go, which 
costs $14.99. (An optional in-app purchase for $4.99 adds Pro 
features, including metadata-only syncing, support for viewing email 
messages and .csv or .tsv documents, and annotating PDFs.) 

To be clear, I’m talking here about DEVONthink To Go version 2, 
which was released in August 2016. Version 1, covered in the previous 
edition of this book, was much more limited in its capabilities; it was 
also slow to sync and generally cumbersome to use. But version 2, 
which was rewritten from scratch, is far better—it’s fast and capable, 
and I find it a real joy to use. 

Although even DEVONthink To Go 2 doesn’t have all the features that 
the desktop versions of DEVONthink do, it does have a surprisingly 
rich range of capabilities for viewing, creating, capturing, and manag-
ing information directly on your iOS device. 

If you have no iOS device, or if you’re not interested in taking your 
DEVONthink data with you, there’s nothing to see here—move on to 
the next chapter, Get Information Out of DEVONthink. Otherwise, 
keep reading to learn about using this extremely handy tool. 

Get to Know DEVONthink To Go
 

Just as DEVONthink for Mac is a complex product, DEVONthink To 
Go is quite deep, with a huge number of features that may not be 
obvious at first glance. Detailing all those features would require its 
own book, and I can offer only an overview in this chapter. I do, 
however, suggest that you download the manual for DEVONthink To 
Go, which is available in PDF, EPUB, and Mobipocket formats. 
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So, what can DEVONthink To Go do? It appears to have, at a rough 
guess, about 75 percent of the capabilities of the desktop versions of 
DEVONthink. For example, here’s a partial list of what you can do in 
DEVONthink To Go: 

•	 Sync data from DEVONthink for Mac (or DEVONthink To Go 
running on other iOS devices) via Dropbox, WebDAV, or a direct 
Wi-Fi connection. 

•	 View any document type supported by iOS. 

•	 Capture data from other apps (such as bookmarks, PDFs, text, and 
images) to a specific database or your global Inbox. 

•	 Create new databases, groups, and tags. 

•	 Create and edit documents in plain text, rich text, Markdown, and 
formatted note formats; rotate and apply filters to graphics; anno-
tate PDFs; and convert (most) documents to other formats. 

•	 Move, duplicate, replicate, group, tag, or delete items. 

•	 Use complex search criteria to find your documents. 

•	 Share documents using the iOS Share sheet. 

However, you should also be aware of some limitations compared to 
the desktop versions of DEVONthink. Among the features DEVON-
think To Go does not include are the following: 

•	 Syncing via iCloud Drive 

•	 Indexing documents stored elsewhere on your iOS device 

•	 Creating new smart groups, or using smart groups created on your 
Mac (only a handful of built-in smart groups are available) 

•	 Editing RTFD documents (RTF with graphics) 

•	 Performing OCR on photos or scanned documents 

•	 Splitting or merging documents 

•	 The Concordance view 
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Get Information Out of 
DEVONthink 

Ordinarily, you’ll interact with the data in your DEVONthink database 
using DEVONthink itself. However, in some cases you may want to 
give others (on your local network or around the world) live access to 
your information—or make your DEVONthink database available to 
yourself when you’re using a computer without DEVONthink installed. 
DEVONthink Pro Office’s built-in Web server lets you do just that. 
And, if the need arises, you can export or share static information from 
DEVONthink in a dizzying array of formats to suit almost any need. 

Tip: If you’re setting up a DEVONthink-based Web server in order to 
share your data with others, read the sidebar Choosing a Sharing 
Strategy, earlier, to make sure you are aware of your sharing 
options, just in case one of the others is a better match for your 
needs. 

Use DEVONthink’s Web Server
 

DEVONthink Pro Office has a built-in Web server that lets you share 
your database live over the Web. This is useful for giving yourself (or 
other family members) access to your data from other computers in 
your home, or for running an internal Web site that provides shared 
information for all the employees of a small company. It also makes it 
possible to add new information to your database from a Web browser. 

Note: Web sharing exists only in DEVONthink Pro Office, not in
 

DEVONthink Professional or DEVONthink Personal.
 

I want to emphasize, though, that this is not a full-blown database 
server, and it’s not suitable for running a public Web site. Compared to 
stand-alone servers, DEVONthink lacks many standard security, 
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logging, performance, and customization features. So it’s good at what 
it does—but just bear in mind that what it does is intentionally limited. 

Note: By default, unless the Mac on which you’re running DEVON-
think has its own publicly routable IP address, your database will be 
visible only inside your internal network. It’s possible to work around 
this by using techniques such as port forwarding, but that’s beyond 
the scope of this book. For more information, see Glenn Fleishman’s 
Take Control of Your Apple Wi-Fi Network. 

To set up the Web server, follow these steps: 

1.	 Go to DEVONthink > Preferences > Server (Figure 65). 

Figure 65: Set up DEVONthink’s Web server here. 

2.	 Edit any or all (or none) of the following fields to taste: 

‣	 Incoming Files: Check “Convert images & PDF documents to 
searchable PDF” if you want DEVONthink to perform OCR on all 
images and PDFs uploaded via the Web interface. 

‣	 Bonjour Name: Enter the name your DEVONthink Web server 
will have on the local network. 

‣	 Bonjour Domain: If your local network contains more than 
one Bonjour domain (an unusual situation), enter the domain 
name at which your database will be reachable (to enable proper 
generation of relative links). Most people can ignore this setting. 
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Dig Deeper 
So far, I’ve only scratched the surface of DEVONthink’s vast array of 
capabilities. Although I can’t cover every last feature, I want to wrap 
up this book with a brief discussion of a few key features that are a bit 
more obscure or advanced than what the average user may need on a 
daily basis. I hope you’ll use this information as a starting point to 
explore and experiment with the app on your own. 

Maintain Your Databases
 

In certain situations, your DEVONthink databases can become cor-
rupted. For example, if a system process DEVONthink depends on 
crashes while data is being written, the files may not be stored correct-
ly or completely. Disk errors and other random events having nothing 
to do specifically with DEVONthink can also cause problems with your 
databases. If you begin noticing problems—weird error messages, 
missing documents, groups, or tags, or anything else that’s out of 
whack—you can use any of several techniques to fix them. (And, it 
doesn’t hurt to use these from time to time as a preventive measure, 
even if you haven’t noticed any problems.) 

Verify & Repair 
The Tools > Verify & Repair command checks the selected database for 
errors, and if it finds any, it fixes those it can. So choosing this com-
mand is a quick and easy way to solve many common problems. 

During the repair process, if DEVONthink finds any files in its package 
on disk that don’t have corresponding entries in your database, it 
(re)imports them and puts them in a new group, at the top level of 
your database, called Orphaned Files. You can then move these newly 
adopted documents to the group(s) of your choice. 
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Backup & Optimize 
You can configure DEVONthink to automatically back up and optimize 
its database periodically in DEVONthink > Preferences > Backup. 
(When it does so, it backs up only the files containing metadata and 
indexes, not the documents themselves, which are more usefully 
backed up using Time Machine or your favorite backup utility.) How-
ever, regardless of that setting, you can manually perform the proce-
dure at any time by choosing Tools > Backup & Optimize. 

Warning! If your index is damaged before you choose this 

command, your backup version will be damaged too! So it’s best to
 

do this right after you’ve successfully completed a Verify & Repair.
 
If repairs were unsuccessful for any reason, skip Backup & Optimize
 

for now.
 

Restore from Backup 
If the Verify & Repair command was unable to fix all your database 
problems, you might be best served by going back to your most recent 
backup (assuming you either had automatic backups turned on or 
manually used the Backup & Optimize command relatively recently). 
To do this, choose Tools > Restore Backup, select a backup (usually the 
most recent one is the logical choice), and click Open. DEVONthink 
reverts to the version of the metadata and index stored in that data-
base. It doesn’t hurt, after doing this, to choose Tools > Verify & Repair 
again, just in case your backup was also damaged. 

Rebuild Database 
If all else fails (namely, you still see error messages or weird behavior 
even after Verify & Repair and Restore from Backup), your best course 
of action may be to ditch your index and rebuild it from the raw docu-
ments. Doing so generally preserves your group and tag structure, 
although some metadata may be lost. 

To rebuild your database, choose Tools > Rebuild Database and click 
OK. DEVONthink exports all your documents and then re-imports 
them. 

203
 

Click here to buy the full 217-page “Take Control of Getting Started with DEVONthink 2” for only $15!

https://www.takecontrolbooks.com/cart?add-to-cart=1097


           
 

       
       

        

        
       

        

        
           

  

Learn More 
You can learn more about DEVONthink by consulting any of the 
following resources: 

•	 DEVONthink User Manuals: The official documentation from 
DEVONtechnologies (available in PDF, EPUB, and Mobipocket 
formats) covers other features that didn’t fit into this book. 

•	 DEVONtechnologies User Forum: Share your tips and experiences 
with other DEVONthink users, get problem-solving advice, and 
learn new ways to accomplish tasks in the User Forum. 

•	 Devonian Times: To keep up with news about DEVONtechnologies, 
its products, and more, read Devonian Times, a blog by company 
president Eric Böhnisch-Volkmann. 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments. 

Ebook Extras
 

You can access extras related to this ebook on the Web. Once you’re 
on the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
a subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, as 
well as a link to an author interview. 

•	 Find out if we have any update plans for the ebook. 

If you bought this ebook from the Take Control Web site, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. However, if you bought 
this ebook elsewhere, you can add it to your account manually: 

•	 If you already have a Take Control account, log in to your account, 
and then click the “access extras…” link above. 

•	 If you don’t have a Take Control account, first make one by follow-
ing the directions that appear when you click the “access extras…” 
link above. Then, once you are logged in to your new account, add 
your ebook by clicking the “access extras…” link a second time. 

Note: If you try the directions above and find that your device is 
incompatible with the Take Control Web site, contact us. 

214
 

Click here to buy the full 217-page “Take Control of Getting Started with DEVONthink 2” for only $15!

mailto:tc-comments@tidbits.com
http://www.takecontrolbooks.com/device-advice
mailto:tc-comments@tidbits.com
https://www.takecontrolbooks.com/cart?add-to-cart=1097


 

          
    

           
  

             
           

             
      

         
          

   

 
             

           
            

            
   

            
        

           
               

          
       

About the Author
 

Joe Kissell is the author of numerous books about technology, includ-
ing Take Control of Your Online Privacy and Take Control of 
Dropbox. He is also a contributing editor to TidBITS and a senior 
contributor to Macworld. 

When not writing or speaking, Joe likes to travel, walk, cook, eat, and 
practice t’ai chi. He lives in San Diego with his wife, Morgen Jahnke; 
their sons, Soren and Devin; and their cat, Zora. To contact Joe about 
this book, send him email and please include Take Control of Getting 
Started with DEVONthink 2 in the subject. But note that although Joe is 
happy to receive feedback on this book, he cannot offer any technical 
support for using DEVONthink. 

Shameless Plug 
On my site Joe On Tech, I write about how people can improve their 
relationship with technology. I’d be delighted if you stopped by for a 
visit! You can also sign up for joeMail, my free, low-volume, no-spam 
mailing list, or follow me on Twitter (@joekissell). To learn more about 
me personally, visit JoeKissell.com. 

Acknowledgments 
Many people contributed to this book, and I greatly appreciate all the 
assistance. Special thanks are due to DEVONtechnologies president 
Eric Böhnisch-Volkmann for all his efforts in bringing this book about, 
and to Adam and Tonya Engst. I also want to extend my thanks to the 
many DEVONthink users who contributed details about how they use 
the product—including Matthew Bookspan, Eben Bruyns, Laurence 

215
 

Click here to buy the full 217-page “Take Control of Getting Started with DEVONthink 2” for only $15!

http://www.takecontrolbooks.com/online-privacy?pt=INTERNAL
http://www.takecontrolbooks.com/dropbox?pt=INTERNAL
http://www.takecontrolbooks.com/dropbox?pt=INTERNAL
mailto:joe@joeontech.net?subject=Take%20Control%20of%20Getting%20Started%20with%20DEVONthink%202
http://joeontech.net/
http://joekissell.us2.list-manage.com/subscribe?u=0c38d715348b092c59d6a1b7f&id=bf174844e3
http://www.twitter.com/joekissell
http://joekissell.com/
https://www.takecontrolbooks.com/cart?add-to-cart=1097


        
         

         
        

 

 

         
          

          
           

          

  

    

   

  

     

       

   
        

         
          

        
  

Chen, Cynthia Cheney, Nicole Dornseif, Clemens Fischmeister, Jack 
Forbush, Keene Haywood, Andy Howell, Asaf Keller, Anthony Brettell 
Lodge, Chris Nidel, Basil Rolandsen, Alan Shutko, George R. Silver-
man, Jan Stoltenhoff, Christian Tagsold, Bruce Williamson, and 
Christoph W. Zimmermann. 

About the Publisher
 

TidBITS Publishing Inc., publisher of the Take Control ebook series, 
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Copyright and Fine Print 
Take Control of Getting Started with DEVONthink 2, Third Edition 

ISBN: 978-1-61542-480-1
 

Copyright © 2016, alt concepts inc. All rights reserved.
 

TidBITS Publishing Inc. 50 Hickory Road, Ithaca, NY 14850 USA 

Why Take Control? We designed Take Control electronic books to help readers regain a 

measure of control in an oftentimes out-of-control universe. With Take Control, we also 

work to streamline the publication process so that information about quickly changing 

technical topics can be published while it’s still relevant and accurate. 

Our books are DRM-free: This ebook doesn’t use digital rights management in any 

way because DRM makes life harder for everyone. So we ask a favor of our readers. If you 

want to share your copy of this ebook with a friend, please do so as you would a physical 

book, meaning that if your friend uses it regularly, he or she should buy a copy. Your 

support makes it possible for future Take Control ebooks to hit the Internet long before 

you’d find the same information in a printed book. Plus, if you buy the ebook, you’re 

entitled to any free updates that become available. 

Remember the trees! You have our permission to make a single print copy of this 

ebook for personal use, if you must. Please reference this page if a print service refuses to 

print the ebook for copyright reasons. 

Caveat lector: Although the author and TidBITS Publishing Inc. have made a reasonable 

effort to ensure the accuracy of the information herein, they assume no responsibility for 

errors or omissions. The information in this book is distributed “As Is,” without warranty 

of any kind. Neither TidBITS Publishing Inc. nor the author shall be liable to any person 

or entity for any special, indirect, incidental, or consequential damages, including without 

limitation lost revenues or lost profits, that may result (or that are alleged to result) from 

the use of these materials. In other words, use this information at your own risk. 

It’s just a name: Many of the designations in this ebook used to distinguish products 

and services are claimed as trademarks or service marks. Any trademarks, service marks, 

product names, or named features that appear in this title are assumed to be the property 

of their respective owners. All product names and services are used in an editorial fashion 

only, with no intention of infringement. No such use, or the use of any trade name, is 

meant to convey endorsement or other affiliation with this title. 

We aren’t Apple: This title is an independent publication and has not been authorized, 

sponsored, or otherwise approved by Apple Inc. Because of the nature of this title, it uses 

terms that are registered trademarks or service marks of Apple Inc. If you’re into that sort 

of thing, you can view a complete list of Apple Inc.’s registered trademarks and service 

marks. 
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