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About the Tutorial 

Microsoft Excel is a commercial spreadsheet application, written and distributed 

by Microsoft for Microsoft Windows and Mac OS X. At the time of writing this 

tutorial the Microsoft excel version was 2010 for Microsoft Windows and 2011 for 

Mac OS X. 

Microsoft Excel is a spreadsheet tool capable of performing calculations, 

analyzing data and integrating information from different programs. 

By default, documents saved in Excel 2010 are saved with the .xlsx extension 

whereas the file extension of the prior Excel versions are .xls. 

Audience 

This tutorial has been designed for computer users who would like to learn 

Microsoft Excel in easy and simple steps. It will be highly useful for those 

learners who do not have prior exposure to Microsoft applications.  

Prerequisites 

Before proceeding with this tutorial, you should have a basic understanding of 

Computer peripherals like mouse, keyboard, monitor, screen etc. and their basic 

operations. You should also have the basic skills of file management and folder 

navigations. 

Copyright & Disclaimer 

 Copyright 2017 by Tutorials Point (I) Pvt. Ltd.  

All the content and graphics published in this e-book are the property of 

Tutorials Point (I) Pvt. Ltd.  The user of this e-book is prohibited to reuse, retain, 

copy, distribute or republish any contents or a part of contents of this e-book in 

any manner without written consent of the publisher.   

We strive to update the contents of our website and tutorials as timely and as 

precisely as possible, however, the contents may contain inaccuracies or errors. 

Tutorials Point (I) Pvt. Ltd. provides no guarantee regarding the accuracy, 

timeliness or completeness of our website or its contents including this tutorial. 

If you discover any errors on our website or in this tutorial, please notify us at 

contact@tutorialspoint.com 

 

 

 

mailto:contact@tutorialspoint.com


ii 

 

Table of Contents 

About the Tutorial .................................................................................................................................. i  

Audience ................................................................................................................................................ i 

Prerequisites .......................................................................................................................................... i 

Copyright & Disclaimer ........................................................................................................................... i 

Table of Contents .................................................................................................................................. ii 

1.  EXCEL ─ GETTING STARTED ................................................................................................ 1 

2. EXCEL ─ EXPLORE WINDOW ............................................................................................... 4 

File Tab .................................................................................................................................................. 4 

Quick Access Toolbar ............................................................................................................................. 4 

Ribbon ................................................................................................................................................... 5 

Title Bar ................................................................................................................................................. 5 

Help ....................................................................................................................................................... 5 

Zoom Control ........................................................................................................................................ 5 

View Buttons ......................................................................................................................................... 5 

Sheet Area ............................................................................................................................................. 6 

Row Bar ................................................................................................................................................. 6 

Column Bar ............................................................................................................................................ 6 

Status Bar .............................................................................................................................................. 6 

Dialog Box Launcher .............................................................................................................................. 6 

3. EXCEL ─ BACKSTAGE ........................................................................................................... 7 

Sheet Information ................................................................................................................................. 9 

Sheet Properties .................................................................................................................................... 9 

Exit Backstage View ............................................................................................................................. 10 

 



iii 

 

4.  EXCEL ─ ENTERING VALUES .............................................................................................. 11 

5.  EXCEL ─ MOVE AROUND .................................................................................................. 13 

Moving with Mouse............................................................................................................................. 14 

Moving with Scroll Bars ....................................................................................................................... 15 

Moving with Keyboard ........................................................................................................................ 16 

Moving with Go To Command ............................................................................................................. 17 

6.  EXCEL ─ SAVE WORKBOOK ............................................................................................... 18 

Saving New Sheet ................................................................................................................................ 18 

Saving New Changes ............................................................................................................................ 19 

7.  EXCEL ─ CREATE WORKSHEET .......................................................................................... 21 

Creating New Worksheet ..................................................................................................................... 21 

8.  EXCEL ─ COPY WORKSHEET .............................................................................................. 23 

Copy Worksheet .................................................................................................................................. 23 

9.  EXCEL ─ HIDING WORKSHEET ........................................................................................... 28 

Hiding Worksheet ................................................................................................................................ 28 

Unhiding Worksheet ............................................................................................................................ 28 

10.  EXCEL ─ DELETE WORKSHEET ........................................................................................... 30 

Delete Worksheet................................................................................................................................ 30 

11.  EXCEL ─ CLOSE WORKBOOK ............................................................................................. 32 

Close Workbook .................................................................................................................................. 32 

12.  EXCEL ─ OPEN WORKBOOK .............................................................................................. 34 

13.  EXCEL ─ CONTEXT HELP ................................................................................................... 36 

 

 



iv 

 

14.  EXCEL ─ INSERT DATA ...................................................................................................... 38 

Inserting Data ...................................................................................................................................... 38 

Inserting Formula ................................................................................................................................ 38 

Modifying Cell Content ........................................................................................................................ 39 

15.  EXCEL ─ SELECT DATA ...................................................................................................... 41 

Select with Mouse ............................................................................................................................... 41 

Select with Special ............................................................................................................................... 41 

16.  EXCEL ─ DELETE DATA ...................................................................................................... 44 

Delete with Mouse .............................................................................................................................. 44 

Delete with Delete Key ........................................................................................................................ 44 

Selective Delete for Rows .................................................................................................................... 45 

17.  EXCEL ─ MOVE DATA ........................................................................................................ 46 

18.  EXCEL ─ ROWS AND COLUMNS ........................................................................................ 48 

Row and Column Basics ....................................................................................................................... 48 

Navigation with Rows and Columns .................................................................................................... 48 

Cell Introduction .................................................................................................................................. 49 

19.  EXCEL ─ COPY AND PASTE ................................................................................................ 50 

Copy Paste ........................................................................................................................................... 50 

Copy Paste using Office Clipboard ....................................................................................................... 50 

Copy Paste in Special way .................................................................................................................... 51 

20.  EXCEL ─ FIND AND REPLACE ............................................................................................. 54 

Find and Replace Dialogue................................................................................................................... 54 

Exploring Options ................................................................................................................................ 56 

 

 



v 

 

21.  EXCEL ─ SPELL CHECK ....................................................................................................... 57 

Spell Check Basis ................................................................................................................................. 57 

Exploring Options ................................................................................................................................ 58 

22.  EXCEL ─ ZOOM IN/OUT .................................................................................................... 59 

Zoom Slider ......................................................................................................................................... 59 

Zoom In ............................................................................................................................................... 59 

Zoom Out ............................................................................................................................................ 60 

23.  EXCEL ─ SPECIAL SYMBOLS ............................................................................................... 61 

Using Symbols ..................................................................................................................................... 61 

Using Special Characters ...................................................................................................................... 62 

24.  EXCEL ─ INSERT COMMENTS ............................................................................................ 63 

Adding Comment to Cell ...................................................................................................................... 63 

Modifying Comment ............................................................................................................................ 64 

Formatting Comment .......................................................................................................................... 65 

25.  EXCEL ─ ADD TEXT BOX .................................................................................................... 66 

Text Boxes ........................................................................................................................................... 66 

Adding Text Boxes ............................................................................................................................... 66 

Formatting Text Box ............................................................................................................................ 67 

26.  EXCEL ─ UNDO CHANGES ................................................................................................. 68 

Undo Changes ..................................................................................................................................... 68 

Redo Changes ...................................................................................................................................... 69 

27.  EXCEL ─ SETTING CELL TYPE ............................................................................................. 70 

Formatting Cell .................................................................................................................................... 70 

Various Cell Formats ............................................................................................................................ 70 

 



vi 

 

28.  EXCEL ─ SETTING FONTS .................................................................................................. 72 

Setting Font from Home ...................................................................................................................... 72 

Setting Font from Format Cell Dialogue ............................................................................................... 73 

29.  EXCEL ─ TEXT DECORATION ............................................................................................. 74 

Text-Decoration ................................................................................................................................... 74 

More Text-Decoration Options ............................................................................................................ 75 

30.  EXCEL ─ ROTATE CELLS ..................................................................................................... 76 

Rotating Cell from Home Tab............................................................................................................... 76 

Rotating Cell from Formatting Cell....................................................................................................... 77 

31.  EXCEL ─ SETTING COLORS ................................................................................................ 78 

Changing Background Color ................................................................................................................. 78 

Changing Foreground Color ................................................................................................................. 78 

32.  EXCEL ─ TEXT ALIGNMENTS ............................................................................................. 80 

Change Alignment from Home Tab ...................................................................................................... 80 

Change Alignment from Format Cells .................................................................................................. 80 

Exploring Alignment Options ............................................................................................................... 81 

33.  EXCEL ─ MERGE AND WRAP ............................................................................................. 82 

Merge Cells .......................................................................................................................................... 82 

Additional Options .............................................................................................................................. 83 

Wrap Text and Shrink to Fit ................................................................................................................. 84 

34.  EXCEL ─ BORDERS AND SHADES ....................................................................................... 85 

Apply Borders ...................................................................................................................................... 85 

Apply Shading ...................................................................................................................................... 86 

 

 



vii 

 

35.  EXCEL ─ APPLY FORMATTING ........................................................................................... 87 

Formatting Cells .................................................................................................................................. 87 

Alternative to Placing Background ....................................................................................................... 87 

36.  EXCEL ─ SHEET OPTIONS .................................................................................................. 88 

Sheet Options ...................................................................................................................................... 88 

Options in Sheet Options Dialogue ...................................................................................................... 88 

37.  EXCEL ─ ADJUST MARGINS ............................................................................................... 90 

Margins ............................................................................................................................................... 90 

Center on Page .................................................................................................................................... 92 

38.  EXCEL ─ PAGE ORIENTATION ............................................................................................ 93 

Page Orientation ................................................................................................................................. 93 

Types of Page Orientation ................................................................................................................... 93 

Changing Page Orientation .................................................................................................................. 93 

39.  EXCEL ─ HEADER AND FOOTER ......................................................................................... 95 

Header and Footer............................................................................................................................... 95 

Adding Header and Footer ................................................................................................................... 95 

Other Header and Footer Options ....................................................................................................... 96 

40.  EXCEL ─ INSERT PAGE BREAK ........................................................................................... 97 

Page Breaks ......................................................................................................................................... 97 

Inserting Page Breaks .......................................................................................................................... 97 

Removing Page Breaks ........................................................................................................................ 98 

41.  EXCEL ─ SET BACKGROUND .............................................................................................. 99 

Background Image ............................................................................................................................... 99 

Alternative to Placing Background ....................................................................................................... 99 

 



viii 

 

42.  EXCEL ─ FREEZE PANES .................................................................................................. 100 

Freezing Panes ................................................................................................................................... 100 

Using Freeze Panes ............................................................................................................................ 100 

Unfreeze Panes .................................................................................................................................. 101 

43.  EXCEL ─ CONDITIONAL FORMAT .................................................................................... 102 

Conditional Formatting ...................................................................................................................... 102 

Various Conditional Formatting Options ........................................................................................... 102 

44.  EXCEL ─ CREATING FORMULAS ...................................................................................... 106 

Formulas in MS Excel ......................................................................................................................... 106 

Elements of Formulas ........................................................................................................................ 106 

Creating Formula ............................................................................................................................... 107 

45.  EXCEL ─ COPYING FORMULAS ........................................................................................ 108 

Copying Formulas in MS Excel ........................................................................................................... 108 

Relative Cell Addresses ...................................................................................................................... 108 

46.  EXCEL ─ FORMULA REFERENCE ...................................................................................... 110 

Cell References in Formulas ............................................................................................................... 110 

Relative Cell References .................................................................................................................... 110 

Absolute Cell References ................................................................................................................... 110 

Mixed Cell References ....................................................................................................................... 111 

47.  EXCEL ─ USING FUNCTIONS............................................................................................ 112 

Functions in Formula ......................................................................................................................... 112 

Using Functions ................................................................................................................................. 112 

Function Arguments .......................................................................................................................... 114 

 

 



ix 

 

48.  EXCEL ─ BUILT-IN FUNCTIONS ........................................................................................ 115 

Built In Functions ............................................................................................................................... 115 

Functions by Categories ..................................................................................................................... 115 

49.  EXCEL ─ DATA FILTERING ............................................................................................... 118 

Filters in MS Excel .............................................................................................................................. 118 

Using Multiple Filters......................................................................................................................... 119 

50.  EXCEL ─ DATA SORTING ................................................................................................. 120 

Sorting in MS Excel ............................................................................................................................ 120 

51.  EXCEL ─ USING RANGES ................................................................................................. 123 

Ranges in MS Excel ............................................................................................................................ 123 

Selecting Ranges ................................................................................................................................ 123 

Selecting Complete Rows and Columns ............................................................................................. 124 

52.  EXCEL ─ DATA VALIDATION ............................................................................................ 125 

Data Validation.................................................................................................................................. 125 

Validation Criteria ............................................................................................................................. 125 

Settings Tab ....................................................................................................................................... 126 

Input Message Tab ............................................................................................................................ 127 

Error Alert Tab ................................................................................................................................... 128 

53.  EXCEL ─ USING STYLES ................................................................................................... 129 

Using Styles in MS Excel..................................................................................................................... 129 

Applying Styles .................................................................................................................................. 129 

Creating Custom Style in MS Excel ..................................................................................................... 130 

 

 

 

 



x 

 

54.  EXCEL ─ USING THEMES ................................................................................................. 132 

Using Themes in MS Excel ................................................................................................................. 132 

Applying Themes ............................................................................................................................... 132 

Creating Custom Theme in MS Excel .................................................................................................. 132 

55.  EXCEL ─ USING TEMPLATES ............................................................................................ 133 

Using Templates in MS Excel ............................................................................................................. 133 

Viewing Available Templates ............................................................................................................. 133 

On-line Templates ............................................................................................................................. 134 

56.  EXCEL ─ USING MACROS ................................................................................................ 135 

Macros in MS Excel ............................................................................................................................ 135 

Macro Options ................................................................................................................................... 135 

Creating Macros ................................................................................................................................ 136 

Edit Macro ......................................................................................................................................... 137 

57.  EXCEL ─ ADDING GRAPHICS ........................................................................................... 138 

Graphic Objects in MS Excel .............................................................................................................. 138 

Insert Shape ...................................................................................................................................... 138 

Insert Smart Art ................................................................................................................................. 139 

Insert Clip Art .................................................................................................................................... 140 

Insert Word Art ................................................................................................................................. 141 

58.  EXCEL ─ CROSS REFERENCING ........................................................................................ 142 

Graphic Objects in MS Excel .............................................................................................................. 142 

VLOOKUP .......................................................................................................................................... 142 

VLOOKUP Example ............................................................................................................................ 142 

 

 

 



xi 

 

59.  EXCEL ─ PRINTING WORKSHEETS ................................................................................... 145 

Quick Print ......................................................................................................................................... 145 

Adjusting Common Page Setup Settings ............................................................................................ 145 

Choosing Your Printer ........................................................................................................................ 146 

Specifying What You Want to Print ................................................................................................... 147 

60.  EXCEL ─ EMAIL WORKBOOKS ......................................................................................... 148 

Email Workbook ................................................................................................................................ 148 

61.  EXCEL ─ TRANSLATE WORKSHEET .................................................................................. 150 

Translate Worksheet ......................................................................................................................... 150 

Performing Translation Step By Step ................................................................................................. 150 

62.  EXCEL ─ WORKBOOK SECURITY ...................................................................................... 151 

Workbook Security ............................................................................................................................ 151 

Protect Worksheet ............................................................................................................................ 151 

Protecting a Workbook ...................................................................................................................... 152 

Requiring a Password to Open a Workbook ...................................................................................... 153 

Protecting Workbook’s Structure and Windows ................................................................................ 154 

63.  EXCEL ─ DATA TABLES .................................................................................................... 155 

Data Tables ........................................................................................................................................ 155 

Data Table with Example ................................................................................................................... 155 

64.  EXCEL ─ PIVOT TABLES ................................................................................................... 158 

Pivot Tables ....................................................................................................................................... 158 

Pivot Table Example .......................................................................................................................... 158 

65.  EXCEL ─ SIMPLE CHARTS ................................................................................................ 161 

Charts ................................................................................................................................................ 161 

Types of Charts .................................................................................................................................. 161 



xii 

 

Creating Chart ................................................................................................................................... 163 

Editing Chart ...................................................................................................................................... 164 

66.  EXCEL ─ PIVOT CHARTS .................................................................................................. 165 

Pivot Charts ....................................................................................................................................... 165 

Pivot Chart Example .......................................................................................................................... 165 

67.  EXCEL ─ KEYBOARD SHORTCUTS .................................................................................... 167 

MS Excel Keyboard Short-cuts ........................................................................................................... 167 

 

 



Excel 2010 

1 

 

This chapter teaches you how to start an excel 2010 application in simple steps. 

Assuming you have Microsoft Office 2010 installed in your PC, start the excel 

application following the below mentioned steps in your PC. 

Step 1: Click on the Start button. 
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Step 2: Click on All Programs option from the menu. 

 
 

Step 3: Search for Microsoft Office from the sub menu and click it. 
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Step 4: Search for Microsoft Excel 2010 from the submenu and click it. 

 
 

This will launch the Microsoft Excel 2010 application and you will see the 

following excel window. 

 



Excel 2010 

4 

 

The following basic window appears when you start the excel application. Let us 

now understand the various important parts of this window. 

 

File Tab 

The File tab replaces the Office button from Excel 2007. You can click it to check 

the Backstage view, where you come to open or save files, create new sheets, 

print a sheet, and do other file-related operations. 

Quick Access Toolbar 

You will find this toolbar just above the File tab and its purpose is to provide a 

convenient resting place for the Excel’s most frequently used commands. You 

can customize this toolbar based on your comfort. 

2. Excel ─ Explore Window 
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Ribbon 

 

Ribbon contains commands organized in three components: 

 Tabs: They appear across the top of the Ribbon and contain groups of 

related commands. Home, Insert, Page Layout are the examples of ribbon 

tabs. 

 Groups: They organize related commands; each group name appears 

below the group on the Ribbon. For example, group of commands related 

to fonts or group of commands related to alignment etc. 

 Commands: Commands appear within each group as mentioned above. 

Title Bar 

This lies in the middle and at the top of the window. Title bar shows the program 

and the sheet titles. 

Help 

The Help Icon can be used to get excel related help anytime you like. This 

provides nice tutorial on various subjects related to excel. 

Zoom Control 

Zoom control lets you zoom in for a closer look at your text. The zoom control 

consists of a slider that you can slide left or right to zoom in or out. The + 

buttons can be clicked to increase or decrease the zoom factor. 

View Buttons 

The group of three buttons located to the left of the Zoom control, near the 

bottom of the screen, lets you switch among excel's various sheet views. 

 Normal Layout view: This displays the page in normal view. 

 Page Layout view: This displays pages exactly as they will appear when 

printed. This gives a full screen look of the document. 

 Page Break view: This shows a preview of where pages will break when 

printed. 
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Sheet Area 

The area where you enter data. The flashing vertical bar is called the insertion 

point and it represents the location where text will appear when you type. 

Row Bar 

Rows are numbered from 1 onwards and keeps on increasing as you keep 

entering data. Maximum limit is 1,048,576 rows. 

Column Bar 

Columns are numbered from A onwards and keeps on increasing as you keep 

entering data. After Z, it will start the series of AA, AB and so on. Maximum limit 

is 16,384 columns. 

Status Bar 

This displays the sheet information as well as the insertion point location. From 

left to right, this bar can contain the total number of pages and words in the 

document, language etc. 

You can configure the status bar by right-clicking anywhere on it and by 

selecting or deselecting options from the provided list. 

Dialog Box Launcher 

This appears as a very small arrow in the lower-right corner of many groups on 

the Ribbon. Clicking this button opens a dialog box or task pane that provides 

more options about the group. 
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The Backstage view has been introduced in Excel 2010 and acts as the central 

place for managing your sheets. The backstage view helps in - creating new 

sheets, saving and opening sheets, printing and sharing sheets, and so on. 

Getting to the Backstage View is easy. Just click the File tab located in the 

upper-left corner of the Excel Ribbon. If you already do not have any opened 

sheet then you will see a window listing down all the recently opened sheets as 

follows: 

 

If you already have an opened sheet then it will display a window showing the 

details about the opened sheet as shown below. Backstage view shows three 

columns when you select most of the available options in the first column. 

3. Excel ─ Backstage 
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First column of the backstage view will have the following options: 

Option Description 

Save 
If an existing sheet is opened, it would be saved as is, 
otherwise it will display a dialogue box asking for the 

sheet name. 

Save As 

A dialogue box will be displayed asking for sheet name 

and sheet type. By default, it will save in sheet 2010 
format with extension .xlsx. 

Open This option is used to open an existing excel sheet. 

Close This option is used to close an opened sheet. 

Info 
This option displays the information about the opened 
sheet. 

Recent This option lists down all the recently opened sheets. 
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New This option is used to open a new sheet. 

Print This option is used to print an opened sheet. 

Save & Send 
This option saves an opened sheet and displays options to 
send the sheet using email etc. 

Help 
You can use this option to get the required help about 
excel 2010. 

Options Use this option to set various option related to excel 2010. 

Exit Use this option to close the sheet and exit. 

Sheet Information 

When you click Info option available in the first column, it displays the following 

information in the second column of the backstage view: 

 Compatibility Mode: If the sheet is not a native excel 2007/2010 sheet, 
a Convert button appears here, enabling you to easily update its format. 

Otherwise, this category does not appear. 

 Permissions: You can use this option to protect the excel sheet. You can 
set a password so that nobody can open your sheet, or you can lock the 

sheet so that nobody can edit your sheet. 

 Prepare for Sharing: This section highlights important information you 
should know about your sheet before you send it to others, such as a 

record of the edits you made as you developed the sheet. 

 Versions: If the sheet has been saved several times, you may be able to 
access previous versions of it from this section. 

Sheet Properties 

When you click Info option available in the first column, it displays various 

properties in the third column of the backstage view. These properties include 

sheet size, title, tags, categories etc. 

You can also edit various properties. Just try to click on the property value and if 

property is editable, then it will display a text box where you can add your text 

like title, tags, comments, Author. 
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Exit Backstage View 

It is simple to exit from the Backstage View. Either click on the File tab or press 

the Esc button on the keyboard to go back to excel working mode. 
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Entering values in excel sheet is a child’s play and this chapter shows how to 

enter values in an excel sheet. A new sheet is displayed by default when you 

open an excel sheet as shown in the below screen shot. 

 
Sheet area is the place where you type your text. The flashing vertical bar is 

called the insertion point and it represents the location where text will appear 

when you type. When you click on a box then the box is highlighted. When you 

double click the box, the flashing vertical bar appears and you can start entering 

your data. 

So, just keep your mouse cursor at the text insertion point and start typing 

whatever text you would like to type. We have typed only two words "Hello 

Excel" as shown below. The text appears to the left of the insertion point as you 

type. 

4. Excel ─ Entering Values 
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There are following three important points, which would help you while typing: 

 Press Tab to go to next column. 

 Press Enter to go to next row. 

 Press Alt + Enter to enter a new line in the same column. 
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Excel provides a number of ways to move around a sheet using the mouse and 

the keyboard. 

First of all, let us create some sample text before we proceed. Open a new excel 

sheet and type any data. We've shown a sample data in the screenshot. 

OrderDate Region Rep Item Units Unit Cost Total 

1/6/2010 East Jones Pencil 95 1.99 189.05 

1/23/2010 Central Kivell Binder 50 19.99 999.5 

2/9/2010 Central Jardine Pencil 36 4.99 179.64 

2/26/2010 Central Gill Pen 27 19.99 539.73 

3/15/2010 West Sorvino Pencil 56 2.99 167.44 

4/1/2010 East Jones Binder 60 4.99 299.4 

4/18/2010 Central Andrews Pencil 75 1.99 149.25 

5/5/2010 Central Jardine Pencil 90 4.99 449.1 

5/22/2010 West Thompson Pencil 32 1.99 63.68 

6/8/2010 East Jones Binder 60 8.99 539.4 

6/25/2010 Central Morgan Pencil 90 4.99 449.1 

7/12/2010 East Howard Binder 29 1.99 57.71 

7/29/2010 East Parent Binder 81 19.99 1,619.19 

8/15/2010 East Jones Pencil 35 4.99 174.65 

5. Excel ─ Move Around 
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Moving with Mouse 

You can easily move the insertion point by clicking in your text anywhere on the 

screen. Sometime if the sheet is big then you cannot see a place where you 

want to move. In such situations, you would have to use the scroll bars, as 

shown in the following screen shot: 
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You can scroll your sheet by rolling your mouse wheel, which is equivalent to 

clicking the up-arrow or down-arrow buttons in the scroll bar. 

Moving with Scroll Bars 

As shown in the above screen capture, there are two scroll bars: one for moving 

vertically within the sheet, and one for moving horizontally. Using the vertical 

scroll bar, you may: 

 Move upward by one line by clicking the upward-pointing scroll arrow. 

 Move downward by one line by clicking the downward-pointing scroll 

arrow. 

 Move one next page, using next page button (footnote). 

 Move one previous page, using previous page button (footnote). 

 Use Browse Object button to move through the sheet, going from one 

chosen object to the next. 
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Moving with Keyboard 

The following keyboard commands, used for moving around your sheet, also 

move the insertion point: 

Keystroke Where the Insertion Point Moves 

 

Forward one box 

 

Back one box 

 

Up one box 

 

Down one box 

PageUp To the previous screen 

PageDown To the next screen 

Home To the beginning of the current screen 

End To the end of the current screen 

You can move box by box or sheet by sheet. Now click in any box containing 

data in the sheet. You would have to hold down the Ctrl key while pressing an 

arrow key, which moves the insertion point as described here: 

Key 

Combination 

Where the Insertion Point Moves 

Ctrl +  To the last box containing data of the current row. 

Ctrl +  To the first box containing data of the current row. 

Ctrl +  
To the first box containing data of the current column. 

Ctrl +  
To the last box containing data of the current column. 
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Ctrl + PageUp To the sheet in the left of the current sheet. 

Ctrl + PageDown To the sheet in the right of the current sheet. 

Ctrl + Home To the beginning of the sheet. 

Ctrl + End To the end of the sheet. 

Moving with Go To Command 

Press F5 key to use Go To command, which will display a dialogue box where 

you will find various options to reach to a particular box. 

Normally, we use row and column number, for example K5 and finally press Go 

To button. 
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Saving New Sheet 

Once you are done with typing in your new excel sheet, it is time to save your 

sheet/workbook to avoid losing work you have done on an Excel sheet. Following 

are the steps to save an edited excel sheet: 

Step 1: Click the File tab and select Save As option. 

 

Step 2: Select a folder where you would like to save the sheet, Enter file name, 

which you want to give to your sheet and Select a Save as type, by default it 

is .docx format. 

6. Excel ─ Save Workbook 
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Step 3: Finally, click on Save button and your sheet will be saved with the 

entered name in the selected folder. 

Saving New Changes 

There may be a situation when you open an existing sheet and edit it partially or 

completely, or even you would like to save the changes in between editing of the 

sheet. If you want to save this sheet with the same name, then you can use 

either of the following simple options: 

 Just press Ctrl + S keys to save the changes. 
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 Optionally, you can click on the floppy icon available at the top left corner 

and just above the File tab. This option will also save the changes. 

 You can also use third method to save the changes, which is 

the Save option available just above the Save As option, as shown in the 

above screen capture. 

If your sheet is new and it was never saved so far, then with either of the three 

options, word would display you a dialogue box to let you select a folder, and 

enter sheet name as explained in case of saving new sheet. 
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Creating New Worksheet 

Three new blank sheets always open when you start Microsoft Excel. Below steps 

explain you how to create a new worksheet if you want to start another new 

worksheet while you are working on a worksheet, or you closed an already 

opened worksheet and want to start a new worksheet. 

Step 1: Right Click the Sheet Name and select Insert option. 

 

Step 2: Now you'll see the Insert dialog with select Worksheet option as 

selected from the general tab. Click the Ok button. 

7. Excel ─ Create Worksheet 
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Now you should have your blank sheet as shown below ready to start typing 

your text. 

 

You can use a short cut to create a blank sheet anytime. Try using 

the Shift+F11 keys and you will see a new blank sheet similar to the above 

sheet is opened. 
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Copy Worksheet 

First of all, let us create some sample text before we proceed. Open a new excel 

sheet and type any data. We've shown a sample data in the screenshot. 

OrderDate Region Rep Item Units Unit Cost Total 

1/6/2010 East Jones Pencil 95 1.99 189.05 

1/23/2010 Central Kivell Binder 50 19.99 999.5 

2/9/2010 Central Jardine Pencil 36 4.99 179.64 

2/26/2010 Central Gill Pen 27 19.99 539.73 

3/15/2010 West Sorvino Pencil 56 2.99 167.44 

4/1/2010 East Jones Binder 60 4.99 299.4 

4/18/2010 Central Andrews Pencil 75 1.99 149.25 

5/5/2010 Central Jardine Pencil 90 4.99 449.1 

5/22/2010 West Thompson Pencil 32 1.99 63.68 

6/8/2010 East Jones Binder 60 8.99 539.4 

6/25/2010 Central Morgan Pencil 90 4.99 449.1 

7/12/2010 East Howard Binder 29 1.99 57.71 

7/29/2010 East Parent Binder 81 19.99 1,619.19 

8/15/2010 East Jones Pencil 35 4.99 174.65 

8. Excel ─ Copy Worksheet 
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Here are the steps to copy an entire worksheet. 

Step 1: Right Click the Sheet Name and select the Move or Copy option. 
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Step 2: Now you'll see the Move or Copy dialog with select Worksheet option as 

selected from the general tab. Click the Ok button. 
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Select Create a Copy Checkbox to create a copy of the current sheet and 

Before sheet option as (move to end) so that new sheet gets created at the 

end. 

Press the Ok Button. 

Now you should have your copied sheet as shown below. 
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You can rename the sheet by double clicking on it. On double click, the sheet 

name becomes editable. Enter any name say Sheet5 and press Tab or Enter 

Key. 
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Hiding Worksheet 

Here is the step to hide a worksheet. 

Step: Right Click the Sheet Name and select the Hide option. Sheet will get 

hidden. 

 

Unhiding Worksheet 

Here are the steps to unhide a worksheet. 

Step 1: Right Click on any Sheet Name and select the Unhide... option. 

9. Excel ─ Hiding Worksheet 
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Step 2: Select Sheet Name to unhide in Unhide dialog to unhide the sheet. 

Press the Ok Button. 

Now you will have your hidden sheet back. 

 



Excel 2010 

30 

 

Delete Worksheet 

Here is the step to delete a worksheet. 

Step: Right Click the Sheet Name and select the Delete option. 

 

Sheet will get deleted if it is empty, otherwise you'll see a confirmation message. 

10. Excel ─ Delete Worksheet 
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Press the Delete Button. 

Now your worksheet will get deleted. 
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Close Workbook 

Here are the steps to close a workbook. 

Step 1: Click the Close Button as shown below. 

 

You'll see a confirmation message to save the workbook. 

11. Excel ─ Close Workbook 
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Step 2: Press the Save Button to save the workbook as we did in MS Excel - 

Save Workbook chapter. 

Now your worksheet will get closed. 
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Let us see how to open workbook from excel in the below mentioned steps. 

Step 1: Click the File Menu as shown below. You can see the Open option in File 

Menu. There are two more columns - Recent workbooks and Recent places, 

where you can see the recently opened workbooks and the recent places from 

where workbooks are opened. 

 
Step 2: Clicking the Open Option will open the browse dialog as shown below. 

Browse the directory and find the file you need to open. 

12. Excel ─ Open Workbook 
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Step 3: Once you select the workbook, your workbook will be opened as below: 
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MS Excel provides context sensitive help on mouse over. To see context 

sensitive help for a particular Menu option, hover the mouse over the option for 

some time. Then you can see the context sensitive Help as shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

13. Excel ─ Context Help 
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Getting More Help 

For getting more help with MS Excel from Microsoft you can press F1 or by File -

> Help -> Support -> Microsoft Office Help. 
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In MS Excel, there are 1048576*16384 cells. MS Excel cell can have Text, 

Numeric value or formulas. An MS Excel cell can have maximum of 32000 

characters. 

Inserting Data 

For inserting data in MS Excel, just activate the cell type text or number and 

press enter or Navigation keys. 

 

Inserting Formula 

For inserting formula in MS Excel go to the formula bar, enter the formula and 

then press enter or navigation key. See the screen-shot below to understand it. 

14. Excel ─ Insert Data 
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Modifying Cell Content 

For modifying the cell content just activate the cell, enter a new value and then 

press enter or navigation key to see the changes. See the screen-shot below to 

understand it. 
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MS Excel provides various ways of selecting data in the sheet. Let us see those 

ways. 

Select with Mouse 

Drag the mouse over the data you want to select. It will select those cells as 

shown below. 

 

Select with Special 

If you want to select specific region, select any cell in that region. 

Pressing F5 will show the below dialogue box. 

15. Excel ─ Select Data 
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Click on Special button to see the below dialogue box. Select current 

region from the radio buttons. Click on ok to see the current region selected. 
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As you can see in the below screen, the data is selected for the current region. 
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MS Excel provides various ways of deleting data in the sheet. Let us see those 

ways. 

Delete with Mouse 

Select the data you want to delete. Right Click on the sheet. Select the delete 

option, to delete the data. 

 

Delete with Delete Key 

Select the data you want to delete. Press on the Delete Button from the 

keyboardto delete the data. 

 

 

 

16. Excel ─ Delete Data 
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Selective Delete for Rows 

Select the rows, which you want to delete with Mouse click + Control 

Key. Then right click to show the various options. Select the Delete option to 

delete the selected rows. 
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Let us see how we can Move Data with MS Excel.  

Step 1: Select the data you want to Move. Right Click and select the cut 

option. 

 
 

 

 

 

 

 

 

 

 

 

 

17. Excel ─ Move Data 
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Step 2: Select the first cell where you want to move the data. Right click on it 

and paste the data. You can see the data is moved now. 
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Row and Column Basics 

MS Excel is in tabular format consisting of rows and columns. 

 Row runs horizontally while Column runs vertically. 

 Each row is identified by row number, which runs vertically at the left side 

of the sheet. 

 Each column is identified by column header, which runs horizontally at the 

top of the sheet. 

For MS Excel 2010, Row numbers ranges from 1 to 104857; in 

total 1048576 rows, and Columns ranges from A to XFD; in 

total 16384 columns. 

Navigation with Rows and Columns 

Let us see how to move to the last row or the last column. 

 You can go to the last row by clicking Control + Down Navigation 

arrow. 

 You can go to the last column by clicking Control + Right Navigation 

arrow. 

 

18. Excel ─ Rows and Columns 
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Cell Introduction 

The intersection of rows and columns is called cell. 

Cell is identified with Combination of column header and row number. 

For example: A1, A2 
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MS Excel provides copy paste option in different ways. The simplest method of 

copy paste is as below. 

Copy Paste 

 To copy and paste, just select the cells you want to copy. Choose copy 

option after right click or press Control + C. 

 Select the cell where you need to paste this copied content. Right click 

and select paste option or press Control + V. 

 

In this case, MS Excel will copy everything such as values, formulas, Formats, 

Comments and validation. MS Excel will overwrite the content with paste. If you 

want to undo this, press Control + Z from the keyboard. 

Copy Paste using Office Clipboard 

When you copy data in MS Excel, it puts the copied content in Windows and 

Office Clipboard. You can view the clipboard content by Home -> Clipboard. 

View the clipboard content. Select the cell where you need to paste. Click on 

paste, to paste the content. 

19. Excel ─ Copy and Paste 
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Copy Paste in Special way 

You may not want to copy everything in some cases. For example, you want to 

copy only Values or you want to copy only the formatting of cells. Select the 

paste special option as shown below. 
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Below are the various options available in paste special. 

 All: Pastes the cell’s contents, formats, and data validation from the 

Windows Clipboard. 

 Formulas: Pastes formulas, but not formatting. 

 Values: Pastes only values not the formulas. 

 Formats: Pastes only the formatting of the source range. 

 Comments: Pastes the comments with the respective cells. 

 Validation: Pastes validation applied in the cells. 

 All using source theme: Pastes formulas, and all formatting. 

 All except borders: Pastes everything except borders that appear in the 

source range. 

 Column Width: Pastes formulas, and also duplicates the column width of 

the copied cells. 

 Formulas & Number Formats: Pastes formulas and number formatting 

only. 

 Values & Number Formats: Pastes the results of formulas, plus the 

number. 

 Merge Conditional Formatting: This icon is displayed only when the 

copied cells contain conditional formatting. When clicked, it merges the 

copied conditional formatting with any conditional formatting in the 

destination range. 

 Transpose: Changes the orientation of the copied range. Rows become 

columns, and columns become rows. Any formulas in the copied range are 

adjusted so that they work properly when transposed. 
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MS Excel provides Find & Replace option for finding text within the sheet. 

Find and Replace Dialogue 

Let us see how to access the Find & Replace Dialogue. 

To access the Find & Replace, Choose Home -> Find & Select -> Find, or 

press Control + F Key. See the image below. 

 

You can see the Find and Replace dialogue as below. 

20. Excel ─ Find and Replace 
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You can replace the found text with the new text in the Replace tab. 
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Exploring Options 

Now, let us see the various options available under the Find dialogue. 

 Within: Specifying the search should be in Sheet or workbook. 

 Search By: Specifying the internal search method by rows or by columns. 

 Look In: If you want to find text in formula as well, then select this 

option. 

 Match Case: If you want to match the case like lower case or upper case 

of words, then check this option. 

 Match Entire Cell Content: If you want the exact match of the word 

with cell, then check this option. 
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MS Excel provides a feature of Word Processing program called Spelling 

check. We can get rid of the spelling mistakes with the help of spelling check 

feature. 

Spell Check Basis 

Let us see how to access the spell check. 

 To access the spell checker, Choose Review ➪ Spelling or press F7. 

 To check the spelling in just a particular range, select the range before 

you activate the spell checker. 

 If the spell checker finds any words it does not recognize as correct, it 

displays the Spelling dialogue with suggested options. 

 

 

 

21. Excel ─ Spell Check 
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Exploring Options 

Let us see the various options available in spell check dialogue. 

 Ignore Once: Ignores the word and continues the spell check. 

 Ignore All: Ignores the word and all subsequent occurrences of it. 

 Add to Dictionary: Adds the word to the dictionary. 

 Change: Changes the word to the selected word in the Suggestions list. 

 Change All: Changes the word to the selected word in the Suggestions 

list and changes all subsequent occurrences of it without asking. 

 AutoCorrect: Adds the misspelled word and its correct spelling (which 

you select from the list) to the AutoCorrect list. 
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Zoom Slider 

By default, everything on screen is displayed at 100% in MS Excel. You can 

change the zoom percentage from 10% (tiny) to 400% (huge). Zooming doesn’t 

change the font size, so it has no effect on the printed output. 

You can view the zoom slider at the right bottom of the workbook as shown 

below. 

 

Zoom In 

You can zoom in the workbook by moving the slider to the right. It will change 

the only view of the workbook. You can have maximum of 400% zoom in. See 

the below screen-shot. 

22. Excel ─ Zoom In/Out 
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Zoom Out 

You can zoom out the workbook by moving the slider to the left. It will change 

the only view of the workbook. You can have maximum of 10% zoom in. See the 

below screen-shot. 
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If you want to insert some symbols or special characters that are not found on 

the keyboard in that case you need to use the Symbols option. 

Using Symbols 

Go to Insert » Symbols » Symbol to view available symbols. You can see 

many symbols available there like Pi, alpha, beta, etc. 

Select the symbol you want to add and click insert to use the symbol. 

 

 

 

 

 

 

23. Excel ─ Special Symbols 
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Using Special Characters 

Go to Insert » Symbols » Special Characters to view the available special 

characters. You can see many special characters available there like Copyright, 

Registered etc. 

Select the special character you want to add and click insert, to use the special 

character. 
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Adding Comment to Cell 

Adding comment to cell helps in understanding the purpose of cell, what input it 

should have, etc. It helps in proper documentation. 

To add comment to a cell, select the cell and perform any of the actions 

mentioned below. 

 Choose Review » Comments » New Comment. 

 Right-click the cell and choose Insert Comment from available options. 

 Press Shift+F2. 

Initially, a comment consists of Computer's user name. You have to modify it 

with text for the cell comment. 

 

 

 

24. Excel ─ Insert Comments 
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Modifying Comment 

You can modify the comment you have entered before as mentioned below. 

 Select the cell on which the comment appears. 

 Right-click the cell and choose the Edit Comment from the available 

options. 

 Modify the comment. 
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Formatting Comment 

Various formatting options are available for comments. For formatting a 

comment, Right click on cell » Edit comment » Select comment » Right 

click on it » Format comment. With formatting of comment you can change 

the color, font, size, etc. of the comment. 
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Text Boxes 

Text boxes are special graphic objects that combine the text with a rectangular 

graphic object. Text boxes and cell comments are similar in displaying the text 

in rectangular box. But text boxes are always visible, while cell comments 

become visible after selecting the cell. 

Adding Text Boxes 

To add a text box, perform the below actions. 

 Choose Insert » Text Box » choose text box or draw it. 

Initially, the comment consists of Computer's user name. You have to modify it 

with text for the cell comment. 

 

 

25. Excel ─ Add Text Box 
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Formatting Text Box 

After you have added the text box, you can format it by changing the font, font 

size, font style, and alignment, etc. Let us see some of the important options of 

formatting a text box. 

 Fill: Specifies the filling of text box like No fill, solid fill. Also specifying the 

transparency of text box fill. 

 Line Color: Specifies the line color and transparency of the line. 

 Line Style: Specifies the line style and width. 

 Size: Specifies the size of the text box. 

 Properties: Specifies some properties of the text box. 

 Text Box: Specifies text box layout, Auto-fit option and internal margins. 
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Undo Changes 

You can reverse almost every action in Excel by using the Undo command. We 

can undo changes in following two ways. 

 From the Quick access tool-bar » Click Undo. 

 Press Control + Z. 

 

You can reverse the effects of the past 100 actions that you performed by 

executing Undo more than once. If you click the arrow on the right side of the 

Undo button, you see a list of the actions that you can reverse. Click an item in 

that list to undo that action and all the subsequent actions you performed. 

 

 

 

 

26. Excel ─ Undo Changes 
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Redo Changes 

You can again reverse back the action done with undo in Excel by using the Redo 

command. We can redo changes in following two ways. 

 From the Quick access tool-bar » Click Redo. 

 Press Control + Y. 
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Formatting Cell 

MS Excel Cell can hold different types of data like Numbers, Currency, Dates, 

etc. You can set the cell type in various ways as shown below: 

 Right Click on the cell » Format cells » Number. 

 Click on the Ribbon from the ribbon. 

 

Various Cell Formats 

Below are the various cell formats. 

 General: This is the default cell format of Cell. 

 Number: This displays cell as number with separator. 

 Currency: This displays cell as currency i.e. with currency sign. 

 Accounting: Similar to Currency, used for accounting purpose. 

 Date: Various date formats are available under this, like 17-09-2013, 

17th-Sep-2013, etc. 

 Time: Various Time formats are available under this like 1.30PM, 13.30, 

etc. 

27. Excel ─ Setting Cell Type 
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 Percentage: This displays cell as percentage with decimal places like 

50.00%. 

 Fraction: This displays cell as fraction like 1/4, 1/2 etc. 

 Scientific: This displays cell as exponential like 5.6E+01. 

 Text: This displays cell as normal text. 

 Special: Special formats of cell like Zip code, Phone Number. 

 Custom: You can use custom format by using this. 
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You can assign any of the fonts that is installed for your printer to cells in a 

worksheet. 

Setting Font from Home 

You can set the font of the selected text from Home » Font group » select 

the font. 

 

 

 

 

 

 

 

 

28. Excel ─ Setting Fonts 



Excel 2010 

73 

 

Setting Font from Format Cell Dialogue 

 Right click on cell » Format cells » Font Tab 

 Press Control + 1 or Shift + Control + F 
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You can change the text decoration of the cell to change its look and feel. 

Text-Decoration 

Various options are available in Home tab of the ribbon as mentioned below. 

 Bold: It makes the text in bold by choosing Home » Font Group » Click 

B or Press Control + B. 

 Italic: It makes the text italic by choosing Home » Font Group » Click 

I or Press Control + I. 

 Underline: It makes the text as underlined by choosing Home » Font 

Group » Click U or Press Control + U. 

 Double Underline: It makes the text highlighted as double underlined by 

choose Home » Font Group » Click arrow near U » Select Double 

Underline. 

 

 

29. Excel ─ Text Decoration 
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More Text-Decoration Options 

There are more options available for text decoration in Formatting cells » Font 

Tab »Effects cells as mentioned below. 

 Strike-through: It strikes the text in the center vertically. 

 Super Script: It makes the content to appear as a super script. 

 Sub Script: It makes content to appear as a sub script. 
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You can rotate the cell by any degree to change the orientation of the cell. 

Rotating Cell from Home Tab 

Click on the orientation in the Home tab. Choose options available like Angle 

CounterClockwise, Angle Clockwise, etc. 

 

 

 

 

 

 

 

 

30. Excel ─ Rotate Cells 
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Rotating Cell from Formatting Cell 

Right Click on the cell. Choose Format cells » Alignment » Set the degree for 

rotation. 
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You can change the background color of the cell or text color. 

Changing Background Color 

By default the background color of the cell is white in MS Excel. You can change 

it as per your need from Home tab » Font group » Background color. 

 

Changing Foreground Color 

By default, the foreground or text color is black in MS Excel. You can change it 

as per your need from Home tab » Font group » Foreground color. 

31. Excel ─ Setting Colors 
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Also you can change the foreground color by selecting the cell Right click » 

Format cells » Font Tab » Color. 
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If you don’t like the default alignment of the cell, you can make changes in the 

alignment of the cell. Below are the various ways of doing it. 

Change Alignment from Home Tab 

You can change the Horizontal and vertical alignment of the cell. By default, 

Excel aligns numbers to the right and text to the left. Click on the available 

option in the Alignment group in Home tab to change alignment. 

 

Change Alignment from Format Cells 

Right click on the cell and choose format cell. In format cells dialogue, 

choose Alignment Tab. Select the available options from the Vertical alignment 

and Horizontal alignment options. 

32. Excel ─ Text Alignments 



Excel 2010 

81 

 

 

Exploring Alignment Options 

1. Horizontal Alignment: You can set horizontal alignment to Left, Centre, 

Right, etc. 

 Left: Aligns the cell contents to the left side of the cell. 

 Center: Centers the cell contents in the cell. 

 Right: Aligns the cell contents to the right side of the cell. 

 Fill: Repeats the contents of the cell until the cell’s width is filled. 

 Justify: Justifies the text to the left and right of the cell. This option is 

applicable only if the cell is formatted as wrapped text and uses more 

than one line. 

2. Vertical Alignment: You can set Vertical alignment to top, Middle, bottom, 

etc. 

 Top: Aligns the cell contents to the top of the cell. 

 Center: Centers the cell contents vertically in the cell. 

 Bottom: Aligns the cell contents to the bottom of the cell. 

 Justify: Justifies the text vertically in the cell; this option is applicable 

only if the cell is formatted as wrapped text and uses more than one line. 
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Merge Cells 

MS Excel enables you to merge two or more cells. When you merge cells, you 

don’t combine the contents of the cells. Rather, you combine a group of cells 

into a single cell that occupies the same space. 

You can merge cells by various ways as mentioned below. 

 Choose Merge & Center control on the Ribbon, which is simpler. To 

merge cells, select the cells that you want to merge and then click the 

Merge & Center button. 

 

 Choose Alignment tab of the Format Cells dialogue box to merge the 

cells. 

33. Excel ─ Merge and Wrap 
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Additional Options 

The Home » Alignment group » Merge & Center control contains a drop-

down list with these additional options: 

 Merge Across: When a multi-row range is selected, this command 

creates multiple merged cells — one for each row. 

 Merge Cells: Merges the selected cells without applying the Center 

attribute. 

 Unmerge Cells: Unmerges the selected cells. 
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Wrap Text and Shrink to Fit 

If the text is too wide to fit the column width but don’t want that text to spill 

over into adjacent cells, you can use either the Wrap Text option or the Shrink 

to Fit option to accommodate that text. 
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Apply Borders 

MS Excel enables you to apply borders to the cells. For applying border, select 

the range of cells Right Click » Format cells » Border Tab » Select the 

Border Style. 

 

Then you can apply border by Home Tab » Font group »Apply Borders. 

34. Excel ─ Borders and Shades 
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Apply Shading 

You can add shading to the cell from the Home tab » Font Group » Select 

the Color. 
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Formatting Cells 

In MS Excel, you can apply formatting to the cell or range of cells by Right 

Click» Format cells» Select the tab. Various tabs are available as shown 

below. 

 

Alternative to Placing Background 

 Number: You can set the Format of the cell depending on the cell 

content. Find tutorial on this at MS Excel - Setting Cell Type. 

 Alignment: You can set the alignment of text on this tab. Find tutorial on 

this at MS Excel - Text Alignments. 

 Font: You can set the Font of text on this tab. Find tutorial on this at MS 

Excel - Setting Fonts. 

 Border: You can set the border of cell with this tab. Find tutorial on this 

at MS Excel - Borders and Shades. 

 Fill: You can set fill of the cell with this tab. Find tutorial on this at MS 

Excel - Borders and Shades. 

 Protection: You can set cell protection option with this tab. 

35. Excel ─ Apply Formatting 
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Sheet Options 

MS Excel provides various sheet options for printing purpose like generally cell 

gridlines aren’t printed. If you want your printout to include the gridlines, 

Choose Page Layout » Sheet Options group » Gridlines » Check Print. 

 

Options in Sheet Options Dialogue 

 Print Area: You can set the print area with this option. 

 Print Titles: You can set titles to appear at the top for rows and at the 

left for columns. 

 Print: 

o Gridlines: Gridlines to appear while printing worksheet. 

o Black & White: Select this check box to have your color printer print 

the chart in black and white. 

o Draft quality: Select this check box to print the chart using your 

printer’s draft-quality setting. 

36. Excel ─ Sheet Options 
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o Rows & Column Heading: Select this check box to have rows and 

column heading to print. 

 Page Order: 

o Down, then Over: It prints the down pages first and then the right 

pages. 

o Over, then Down: It prints right pages first and then comes to print 

the down pages. 
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Margins 

Margins are the unprinted areas along the sides, top, and bottom of a printed 

page. All printed pages in MS Excel have the same margins. You can’t specify 

different margins for different pages. 

You can set margins by various ways as explained below. 

 Choose Page Layout » Page Setup » Margins drop-down list, you can 

select Normal, Wide, Narrow, or the custom Setting. 

 

 These options are also available when you choose File » Print. 

37. Excel ─ Adjust Margins 



Excel 2010 

91 

 

 

If none of these settings does the job, choose Custom Margins to display the 

Margins tab of the Page Setup dialog box, as shown below. 
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Center on Page 

By default, Excel aligns the printed page at the top and left margins. If you want 

the output to be centered vertically or horizontally, select the appropriate check 

box in the Center on Page section of the Margins tab as shown in the above 

screenshot. 
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Page Orientation 

Page orientation refers to how output is printed on the page. If you change the 

orientation, the onscreen page breaks adjust automatically to accommodate the 

new paper orientation. 

Types of Page Orientation 

 Portrait: Portrait to print tall pages (the default). 

 Landscape: Landscape to print wide pages. Landscape orientation is 

useful when you have a wide range that doesn’t fit on a vertically oriented 

page. 

Changing Page Orientation 

 Choose Page Layout » Page Setup » Orientation » Portrait or Landscape. 

 

 

 

 

38. Excel ─ Page Orientation 
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 Choose File » Print. 
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Header and Footer 

A header is the information that appears at the top of each printed page and a 

footer is the information that appears at the bottom of each printed page. By 

default, new workbooks do not have headers or footers. 

Adding Header and Footer 

 Choose Page Setup dialog box » Header or Footer tab. 

 

You can choose the predefined header and footer or create your custom ones. 

 &[Page] : Displays the page number. 

 &[Pages] : Displays the total number of pages to be printed. 

 &[Date] : Displays the current date. 

 &[Time] : Displays the current time. 

 &[Path]&[File] : Displays the workbook’s complete path and filename. 

 &[File] : Displays the workbook name. 
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 &[Tab] : Displays the sheet’s name. 

Other Header and Footer Options 

When a header or footer is selected in Page Layout view, the Header & Footer 

» Design » Options group contains controls that let you specify other options: 

 Different First Page: Check this to specify a different header or footer 

for the first printed page. 

 Different Odd & Even Pages: Check this to specify a different header or 

footer for odd and even pages. 

 Scale with Document: If checked, the font size in the header and footer 

will be sized. Accordingly if the document is scaled when printed. This 

option is enabled, by default. 

 Align with Page Margins: If checked, the left header and footer will be 

aligned with the left margin, and the right header and footer will be 

aligned with the right margin. This option is enabled, by default. 

 

 

 

 

 

 

 

 

 

 

 



Excel 2010 

97 

 

Page Breaks 

If you don’t want a row to print on a page by itself or you don't want a table 

header row to be the last line on a page. MS Excel gives you precise control 

over page breaks. 

MS Excel handles page breaks automatically, but sometimes you may want to 

force a page break either a vertical or a horizontal one, so that the report 

prints the way you want. 

For example, if your worksheet consists of several distinct sections, you may 

want to print each section on a separate sheet of paper. 

Inserting Page Breaks 

Insert Horizontal Page Break: For example, if you want row 14 to be the first 

row of a new page, select cell A14. Then choose Page Layout » Page Setup 

Group » Breaks» Insert Page Break. 

 

Insert vertical Page break: In this case, make sure to place the pointer in row 

1. Choose Page Layout » Page Setup » Breaks » Insert Page Break to 

create the page break. 
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Removing Page Breaks 

 Remove a page break you’ve added: Move the cell pointer to the first 

row beneath the manual page break and then choose Page Layout » Page 

Setup » Breaks » Remove Page Break. 

 Remove all manual page breaks: Choose Page Layout » Page Setup » 

Breaks » Reset All Page Breaks. 
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Background Image 

Unfortunately, you cannot have a background image on your printouts. You may 

have noticed the Page Layout » Page Setup » Background command. This 

button displays a dialogue box that lets you select an image to display as a 

background. Placing this control among the other print-related commands is 

very misleading. Background images placed on a worksheet are never printed. 

Alternative to Placing Background 

 You can insert a Shape, WordArt, or a picture on your worksheet and then 

adjust its transparency. Then copy the image to all printed pages. 

 You can insert an object in a page header or footer. 
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Freezing Panes 

If you set up a worksheet with row or column headings, these headings will not 

be visible when you scroll down or to the right. MS Excel provides a handy 

solution to this problem with freezing panes. Freezing panes keeps the headings 

visible while you’re scrolling through the worksheet. 

Using Freeze Panes 

Follow the steps mentioned below to freeze panes. 

 Select the First row or First Column or the row Below, which you want to 

freeze, or Column right to area, which you want to freeze. 

 Choose View Tab » Freeze Panes. 

 Select the suitable option: 

o Freeze Panes: To freeze area of cells. 

o Freeze Top Row: To freeze first row of worksheet. 

o Freeze First Column: To freeze first Column of worksheet. 
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 If you have selected Freeze top row you can see the first row appears at 

the top, after scrolling also. See the below screen-shot. 

 

Unfreeze Panes 

To unfreeze Panes, choose View Tab » Unfreeze Panes. 
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Conditional Formatting 

MS Excel 2010 Conditional Formatting feature enables you to format a range of 

values so that the values outside certain limits, are automatically formatted. 

Choose Home Tab » Style group » Conditional Formatting dropdown. 

Various Conditional Formatting Options 

 Highlight Cells Rules: It opens a continuation menu with various options 

for defining the formatting rules that highlight the cells in the cell 

selection that contain certain values, text, or dates, or that have values 

greater or less than a particular value, or that fall within a certain ranges 

of values. 

Suppose you want to find cell with Amount 0 and Mark them as red. 

Choose Range of cell » Home Tab » Conditional Formatting DropDown » 

Highlight Cell Rules » Equal To. 

 

After Clicking ok, the cells with value zero are marked as red. 
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 Top/Bottom Rules: It opens a continuation menu with various options 

for defining the formatting rules that highlight the top and bottom values, 

percentages, and above and below average values in the cell selection. 

Suppose you want to highlight the top 10% rows, you can do this with these 

Top/Bottom rules. 
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 Data Bars: It opens a palette with different color data bars that you can 

apply to the cell selection to indicate their values relative to each other by 

clicking the data bar thumbnail. 

With this conditional Formatting, data Bars will appear in each cell. 

 

 Color Scales: It opens a palette with different three- and two-colored 

scales that you can apply to the cell selection to indicate their values 

relative to each other by clicking the color scale thumbnail. 

See the below screenshot with Color Scales, conditional formatting applied. 
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 Icon Sets: It opens a palette with different sets of icons that you can 

apply to the cell selection to indicate their values relative to each other by 

clicking the icon set. 

See the below screenshot with Icon Sets, conditional formatting applied. 

 

 New Rule: It opens the New Formatting Rule dialog box, where you 

define a custom conditional formatting rule to apply to the cell selection. 

 Clear Rules: It opens a continuation menu, where you can remove the 

conditional formatting rules for the cell selection by clicking the Selected 

Cells option, for the entire worksheet by clicking the Entire Sheet option, 

or for just the current data table by clicking the This Table option. 

 Manage Rules: It opens the Conditional Formatting Rules Manager dialog 

box, where you edit and delete particular rules as well as adjust their rule 

precedence by moving them up or down in the Rules list box. 
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Formulas in MS Excel 

Formulas are the Bread and butter of worksheet. Without formula, worksheet 

will be just simple tabular representation of data. A formula consists of special 

code, which is entered into a cell. It performs some calculations and returns a 

result, which is displayed in the cell. 

Formulas use a variety of operators and worksheet functions to work with values 

and text. The values and text used in formulas can be located in other cells, 

which makes changing data easy and gives worksheets their dynamic nature. 

For example, you can quickly change the data in a worksheet and formulas 

works. 

Elements of Formulas 

A formula can consist of any of these elements: 

 Mathematical operators, such as +(for addition) and *(for 

multiplication) 

Example: 

o =A1+A2 Adds the values in cells A1 and A2. 

 Values or text 

Example: 

o =200*0.5 Multiplies 200 times 0.15. This formula uses only values, 

and it always returns the same result as 100. 

 Cell references (including named cells and ranges) 

Example: 

o =A1=C12 Compares cell A1 with cell C12. If the cells are identical, the 

formula returns TRUE; otherwise, it returns FALSE. 

 Worksheet functions (such as SUMor AVERAGE) 

Example: 

o =SUM(A1:A12) Adds the values in the range A1:A12. 
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Creating Formula 

For creating a formula, you need to type in the Formula Bar. Formula begins 

with '=' sign. When building formulas manually, you can either type in the cell 

addresses or you can point to them in the worksheet. Using the Pointing 

method to supply the cell addresses for formulas is often easier and more 

powerful method of formula building. When you are using built-in functions, you 

click the cell or drag through the cell range that you want to use when defining 

the function’s arguments in the Function Arguments dialog box. See the below 

screen shot. 

 

As soon as you complete a formula entry, Excel calculates the result, which is 

then displayed inside the cell within the worksheet (the contents of the formula, 

however, continue to be visible on the Formula bar anytime the cell is active). If 

you make an error in the formula that prevents Excel from being able to 

calculate the formula at all, Excel displays an Alert dialog box suggesting how to 

fix the problem. 
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Copying Formulas in MS Excel 

Copying formulas is one of the most common tasks that you do in a typical 

spreadsheet that relies primarily on formulas. When a formula uses cell 

references rather than constant values, Excel makes the task of copying an 

original formula to every place that requires a similar formula. 

Relative Cell Addresses 

MS Excel does it automatically adjusting the cell references in the original 

formula to suit the position of the copies that you make. It does this through a 

system known as relative cell addresses, where by the column references in 

the cell address in the formula change to suit their new column position and the 

row references change to suit their new row position. 

Let us see this with the help of example. Suppose we want the sum of all the 

rows at last, then we will write a formula for first column i.e. B. We want sum of 

the rows from 3 to 8 in the 9th row. 
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After writing formula in the 9th row, we can drag it to remaining columns and the 

formula gets copied. After dragging we can see the formula in the remaining 

columns as below. 

 column C : =SUM(C3:C8) 

 column D : =SUM(D3:D8) 

 column E : =SUM(E3:E8) 

 column F : =SUM(F3:F8) 

 column G : =SUM(G3:G8) 
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Cell References in Formulas 

Most formulas you create include references to cells or ranges. These references 

enable your formulas to work dynamically with the data contained in those cells 

or ranges. For example, if your formula refers to cell C2 and you change the 

value contained in C2, the formula result reflects new value automatically. If you 

didn’t use references in your formulas, you would need to edit the formulas 

themselves in order to change the values used in the formulas. 

When you use a cell (or range) reference in a formula, you can use three types 

of references: relative, absolute, and mixed references. 

Relative Cell References 

The row and column references can change when you copy the formula to 

another cell because the references are actually offsets from the current row and 

column. By default, Excel creates relative cell references in formulas. 

 

Absolute Cell References 

The row and column references do not change when you copy the formula 

because the reference is to an actual cell address. An absolute reference uses 
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two dollar signs in its address: one for the column letter and one for the row 

number (for example, $A$5). 

 

Mixed Cell References 

Both the row or column reference is relative and the other is absolute. Only one 

of the address parts is absolute (for example, $A5 or A$5). 
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Functions in Formula 

Many formulas you create use available worksheet functions. These functions 

enable you to greatly enhance the power of your formulas and perform 

calculations that are difficult if you use only the operators. For example, you can 

use the LOG or SIN function to calculate the Logarithm or Sin ratio. You can’t do 

this complicated calculation by using the mathematical operators alone. 

Using Functions 

When you type = sign and then type any alphabet you will see the searched 

functions as below. 

 

Suppose you need to determine the largest value in a range. A formula can’t tell 

you the answer without using a function. We will use formula that uses the MAX 

function to return the largest value in the range B3:B8 as =MAX(A1:D100). 
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Another example of functions. Suppose you want to find if the cell of month is 

greater than 1900 then we can give Bonus to Sales representative. The we can 

achieve it with writing formula with IF functions as =IF(B9>1900,"Yes","No") 
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Function Arguments 

In the above examples, you may have noticed that all the functions used 

parentheses. The information inside the parentheses is the list of arguments. 

Functions vary in how they use arguments. Depending on what it has to do, a 

function may use. 

 No arguments: Examples: Now(),Date(),etc. 

 One argument: UPPER(),LOWER(),etc. 

 A fixed number of arguments: IF(),MAX(),MIN(),AVERGAGE(),etc. 

 Infinite number of arguments 

 Optional arguments 
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Built In Functions 

MS Excel has many built in functions, which we can use in our formula. To see 

all the functions by category, choose Formulas Tab » Insert Function. Then 

Insert function Dialog appears from which we can choose the function. 

 

Functions by Categories 

Let us see some of the built in functions in MS Excel. 

 Text Functions 

o LOWER: Converts all characters in a supplied text string to lower 

case 

o UPPER: Converts all characters in a supplied text string to upper 

case 

o TRIM: Removes duplicate spaces, and spaces at the start and end 

of a text string. 

o CONCATENATE: Joins together two or more text strings. 
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o LEFT: Returns a specified number of characters from the start of a 

supplied text string. 

o MID: Returns a specified number of characters from the middle of a 

supplied text string. 

o RIGHT: Returns a specified number of characters from the end of a 

supplied text string. 

o LEN: Returns the length of a supplied text string. 

o FIND: Returns the position of a supplied character or text string 

from within a supplied text string (case-sensitive). 

 Date & Time 

o DATE: Returns a date, from a user-supplied year, month and day. 

o TIME: Returns a time, from a user-supplied hour, minute and 

second. 

o DATEVALUE: Converts a text string showing a date, to an integer 

that represents the date in Excel's date-time code. 

o TIMEVALUE: Converts a text string showing a time, to a decimal 

that represents the time in Excel. 

o NOW: Returns the current date & time. 

o TODAY: Returns today's date. 

 Statistical 

o MAX: Returns the largest value from a list of supplied numbers. 

o MIN: Returns the smallest value from a list of supplied numbers. 

o AVERAGE: Returns the Average of a list of supplied numbers. 

o COUNT: Returns the number of numerical values in a supplied set 

of cells or values. 

o COUNTIF: Returns the number of cells (of a supplied range), that 

satisfies a given criteria. 

o SUM: Returns the sum of a supplied list of numbers. 

 Logical 

o AND: Tests a number of user-defined conditions and returns TRUE 

if ALL of the conditions evaluate to TRUE, or FALSE otherwise. 

o OR: Tests a number of user-defined conditions and returns TRUE if 

ANY of the conditions evaluate to TRUE, or FALSE otherwise. 
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o NOT: Returns a logical value that is the opposite of a user supplied 

logical value or expression i.e. returns FALSE if the supplied 

argument is TRUE and returns TRUE if the supplied argument is 

FALSE). 

 Math & Trig 

o ABS: Returns the absolute value (i.e. the modulus) of a supplied 

number. 

o SIGN: Returns the sign (+1, -1 or 0) of a supplied number. 

o SQRT: Returns the positive square root of a given number. 

o MOD: Returns the remainder from a division between two supplied 

numbers. 
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Filters in MS Excel 

Filtering data in MS Excel refers to displaying only the rows that meet certain 

conditions. (The other rows gets hidden.) 

Using the store data, if you are interested in seeing data where Shoe Size is 36, 

then you can set filter to do this. Follow the below mentioned steps to do this. 

 Place a cursor on the Header Row. 

 Choose Data Tab » Filter to set filter. 

 

 Click the drop-down arrow in the Area Row Header and remove the check 

mark from Select All, which unselects everything. 

 Then select the check mark for Size 36, which will filter the data and 

displays data of Shoe Size 36. 

 Some of the row numbers are missing; these rows contain the filtered 

(hidden) data. 

 There is drop-down arrow in the Area column now shows a different 

graphic — an icon that indicates the column is filtered. 
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Using Multiple Filters 

You can filter the records by multiple conditions i.e. by multiple column values. 

Suppose after size 36 is filtered, you need to have the filter where color is equal 

to Coffee. After setting filter for Shoe Size, choose Color column and then set 

filter for color. 
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Sorting in MS Excel 

Sorting data in MS Excel rearranges the rows based on the contents of a 

particular column. You may want to sort a table to put names in alphabetical 

order. Or, maybe you want to sort data by Amount from smallest to largest or 

largest to smallest. 

To Sort the data follow the steps mentioned below. 

 Select the Column by which you want to sort data. 

 Choose Data Tab » Sort Below dialog appears. 

 

 If you want to sort data based on a selected column, Choose Continue 

with the selection or if you want sorting based on other columns, 

choose Expand Selection. 

 You can Sort based on the below Conditions. 

o Values: Alphabetically or numerically. 

o Cell Color: Based on Color of Cell. 

o Font Color: Based on Font color. 
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o Cell Icon: Based on Cell Icon. 

 

 Clicking Ok will sort the data. 
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Sorting option is also available from the Home Tab. Choose Home Tab » Sort & 

Filter. You can see the same dialog to sort records. 
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Ranges in MS Excel 

A cell is a single element in a worksheet that can hold a value, some text, or a 

formula. A cell is identified by its address, which consists of its column letter and 

row number. For example, cell B1 is the cell in the second column and the first 

row. 

A group of cells is called a range. You designate a range address by specifying 

its upper-left cell address and its lower-right cell address, separated by a colon 

Example of Ranges: 

 C24: A range that consists of a single cell. 

 A1:B1: Two cells that occupy one row and two columns. 

 A1:A100: 100 cells in column A. 

 A1:D4: 16 cells (four rows by four columns). 

Selecting Ranges 

You can select a range in several ways: 

 Press the left mouse button and drag, highlighting the range. Then release 

the mouse button. If you drag to the end of the screen, the worksheet will 

scroll. 

 Press the Shift key while you use the navigation keys to select a range. 

 Press F8 and then move the cell pointer with the navigation keys to 

highlight the range. Press F8 again to return the navigation keys to 

normal movement. 

 Type the cell or range address into the Name box and press Enter. Excel 

selects the cell or range that you specified. 
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Selecting Complete Rows and Columns 

When you need to select an entire row or column. You can select entire rows 

and columns in much the same manner as you select ranges: 

 Click the row or column border to select a single row or column. 

 To select multiple adjacent rows or columns, click a row or column border 

and drag to highlight additional rows or columns. 

 To select multiple (nonadjacent) rows or columns, press Ctrl while you 

click the row or column borders that you want. 
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Data Validation 

MS Excel data validation feature allows you to set up certain rules that dictate 

what can be entered into a cell. For example, you may want to limit data entry 

in a particular cell to whole numbers between 0 and 10. If the user makes an 

invalid entry, you can display a custom message as shown below. 

 

Validation Criteria 

To specify the type of data allowable in a cell or range, follow the steps below, 

which shows all the three tabs of the Data Validation dialog box. 

 Select the cell or range. 

 Choose Data » Data Tools » Data Validation. Excel displays its Data 

Validation dialog box having 3 tabs settings, Input Message and Error 

alert. 
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Settings Tab 

Here you can set the type of validation you need. Choose an option from the 

Allow drop-down list. The contents of the Data Validation dialog box will change, 

displaying controls based on your choice. 

 Any Value: Selecting this option removes any existing data validation. 

 Whole Number: The user must enter a whole number. For example, you 

can specify that the entry must be a whole number greater than or equal 

to 50. 

 Decimal: The user must enter a number. For example, you can specify 

that the entry must be greater than or equal to 10 and less than or equal 

to 20. 

 List: The user must choose from a list of entries you provide. You will 

create drop-down list with this validation. You have to give input ranges 

then those values will appear in the drop-down. 

 Date: The user must enter a date. You specify a valid date range from 

choices in the Data drop-down list. For example, you can specify that the 

entered data must be greater than or equal to January 1, 2013, and less 

than or equal to December 31, 2013. 

 Time: The user must enter a time. You specify a valid time range from 

choices in the Data drop-down list. For example, you can specify that the 

entered data must be later than 12:00 p.m. 

 Text Length: The length of the data (number of characters) is limited. 

You specify a valid length by using the Data drop-down list. For example, 

you can specify that the length of the entered data be 1 (a single 

alphanumeric character). 

 Custom: To use this option, you must supply a logical formula that 

determines the validity of the user’s entry (a logical formula returns either 

TRUE or FALSE). 
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Input Message Tab 

You can set the input help message with this tab. Fill the title and Input message 

of the Input message tab and the input message will appear when the cell is 

selected. 
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Error Alert Tab 

You can specify an error message with this tab. Fill the title and error message. 

Select the style of the error as stop, warning or Information as per you need. 
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Using Styles in MS Excel 

With MS Excel 2010 Named styles make it very easy to apply a set of 

predefined formatting options to a cell or range. It saves time as well as makes 

sure that look of the cells are consistent. 

A Style can consist of settings for up to six different attributes: 

 Number format 

 Font (type, size, and color) 

 Alignment (vertical and horizontal) 

 Borders 

 Pattern 

 Protection (locked and hidden) 

Now, let us see how styles are helpful. Suppose that you apply a particular style 

to some twenty cells scattered throughout your worksheet. Later, you realize 

that these cells should have a font size of 12 pt. rather than 14 pt. Rather than 

changing each cell, simply edit the style. All cells with that particular style 

change automatically. 

Applying Styles 

Choose Home » Styles » Cell Styles. Note that this display is a live preview, 

that is, as you move your mouse over the style choices, the selected cell or 

range temporarily displays the style. When you see a style you like, click it to 

apply the style to the selection. 
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Creating Custom Style in MS Excel 

We can create new custom style in Excel 2010.To create a new style, follow 

these steps: 

 Select a cell and click on Cell styles from Home Tab. 

 Click on New Cell Style and give style name. 

 Click on Format to apply formatting to the cell. 

 



Excel 2010 

131 

 

 After applying formatting click on OK. This will add new style in the styles. 

You can view it on Home » Styles. 
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Using Themes in MS Excel 

To help users create more professional-looking documents, MS Excel has 

incorporated a concept known as document themes. By using themes, it is easy 

to specify the colors, fonts, and a variety of graphic effects in a document. And 

best of all, changing the entire look of your document is a breeze. A few mouse 

clicks is all it takes to apply a different theme and change the look of your 

workbook. 

Applying Themes 

Choose Page layout Tab » Themes Dropdown. Note that this display is a live 

preview, that is, as you move your mouse over the Theme, it temporarily 

displays the theme effect. When you see a style you like, click it to apply the 

style to the selection. 

Creating Custom Theme in MS Excel 

We can create new custom Theme in Excel 2010. To create a new style, follow 

these steps: 

 Click on the save current theme option under Theme in Page Layout 

Tab. 

 This will save the current theme to office folder. 

 You can browse the theme later to load the theme. 
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Using Templates in MS Excel 

Template is essentially a model that serves as the basis for something. An Excel 

template is a workbook that’s used to create other workbooks. 

Viewing Available Templates 

To view the Excel templates, choose File » New to display the available 

templates screen in Backstage View. You can select a template stored on your 

hard drive, or a template from Microsoft Office Online. If you choose a template 

from Microsoft Office Online, you must be connected to the Internet to download 

it. The Office Online Templates section contains a number of icons, which 

represents various categories of templates. Click an icon, and you’ll see the 

available templates. When you select a template thumbnail, you can see a 

preview in the right panel. 
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On-line Templates 

These template data is available online at the Microsoft server. When you select 

the template and click on it, it will download the template data from Microsoft 

server and opens it as shown below. 
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Macros in MS Excel 

Macros enable you to automate almost any task that you can undertake in Excel 

2010. By using macro recorder from View Tab » Macro Dropdown to record 

tasks that you perform routinely, you not only speed up the procedure 

considerably but you are assured that each step in a task is carried out the same 

way each and every time you perform a task. 

To view macros choose View Tab » Macro dropdown. 

 

Macro Options 

View tab contains a Macros command button to which a dropdown menu 

containing the following three options. 

 View Macros: Opens the Macro dialog box where you can select a macro 

to run or edit. 

 Record Macro: Opens the Record Macro dialog box where you define the 

settings for your new macro and then start the macro recorder; this is the 

same as clicking the Record Macro button on the Status bar. 

 Use Relative References: Uses relative cell addresses when recording a 

macro, making the macro more versatile by enabling you to run it in areas 
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of a worksheet other than the ones originally used in the macro’s 

recording. 

Creating Macros 

You can create macros in one of two ways: 

 Use MS Excel’s macro recorder to record your actions as you undertake 

them in a worksheet. 

 Enter the instructions that you want to be followed in a VBA code in the 

Visual Basic Editor. 

Now let’s create a simple macro that will automate the task of making cell 

content Bold and apply cell color. 

 Choose View Tab » Macro dropdown. 

 Click on Record Macro as below. 

 

 Now Macro recording will start. 

 Do the steps of action, which you want to perform repeatedly. Macro will 

record those steps. 

 You can stop the macro recording once done with all steps. 
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Edit Macro 

You can edit the created Macro at any time. Editing macro will take you to the 

VBA programming editor. 
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Graphic Objects in MS Excel 

MS Excel supports various types of graphic objects like Shapes gallery, 

SmartArt, Text Box, and WordArt available on the Insert tab of the Ribbon. 

Graphics are available in the Insert Tab. See the screenshots below for various 

available graphics in MS Excel 2010. 

 

Insert Shape 

 Choose Insert Tab » Shapes dropdown. 

 Select the shape you want to insert. Click on shape to insert it. 

 To edit the inserted shape just drag the shape with the mouse. Shape will 

adjust the shape. 

57. Excel ─ Adding Graphics 



Excel 2010 

139 

 

 

Insert Smart Art 

 Choose Insert Tab » SmartArt. 

 Clicking SmartArt will open the SmartArt dialogue as shown below in the 

screen-shot. Choose from the list of available smartArts. 

 Click on SmartArt to Insert it in the worksheet. 

 Edit the SmartArt as per your need. 
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Insert Clip Art 

 Choose Insert Tab » Clip Art. 

 Clicking Clip Art will open the search box as shown in the below screen-

shot. Choose from the list of available Clip Arts. 

 Click on Clip Art to Insert it in the worksheet. 
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Insert Word Art 

 Choose Insert Tab » WordArt. 

 Select the style of WordArt, which you like and click it to enter a text in it. 
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Graphic Objects in MS Excel 

When you have information spread across several different spreadsheets, it can 

seem a daunting task to bring all these different sets of data together into one 

meaningful list or table. This is where the Vlookup function comes into its own. 

VLOOKUP 

VlookUp searches for a value vertically down for the lookup table. 

VLOOKUP(lookup_value,table_array,col_index_num,range_lookup) has 4 

parameters as below. 

 lookup_value: It is the user input. This is the value that the function 

uses to search on. 

 The table_array: It is the area of cells in which the table is located. This 

includes not only the column being searched on, but the data columns for 

which you are going to get the values that you need. 

 Col_index_num: It is the column of data that contains the answer that 

you want. 

 Range_lookup: It is a TRUE or FALSE value. When set to TRUE, the 

lookup function gives the closest match to the lookup_value without going 

over the lookup_value. When set to FALSE, an exact match must be found 

to the lookup_value or the function will return #N/A. Note, this requires 

that the column containing the lookup_value be formatted in ascending 

order. 

VLOOKUP Example 

Let's look at a very simple example of cross-referencing two spreadsheets. Each 

spreadsheet contains information about the same group of people. The first 

spreadsheet has their dates of birth, and the second shows their favorite color. 

How do we build a list showing the person's name, their date of birth and their 

favorite color? VLOOOKUP will help in this case. First of all, let us see data in 

both the sheets. 

This is data in the first sheet. 
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This is data in the second sheet. 

 

Now for finding the respective favorite color for that person from another sheet 

we need to vlookup the data. First argument to the VLOOKUP is lookup value (In 
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this case it is person name). Second argument is the table array, which is table 

in the second sheet from B2 to C11. Third argument to VLOOKUP is Column 

index num, which is the answer we are looking for. In this case, it is 2 the color 

column number is 2. The fourth argument is True returning partial match or 

false returning exact match. After applying VLOOKUP formula it will calculate the 

color and the results are displayed as below. 

 

As you can see in the above screen-shot that results of VLOOKUP has searched 

for color in the second sheet table. It has returned #N/A in case where match is 

not found. In this case, Andy's data is not present in the second sheet so it 

returned #N/A. 
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Quick Print 

If you want to print a copy of a worksheet with no layout adjustment, use the 

Quick Print option. There are two ways in which we can use this option. 

 Choose File » Print (which displays the Print pane), and then click the 

Print button. 

 Press Ctrl+P and then click the Print button (or press Enter). 

 

Adjusting Common Page Setup Settings 

You can adjust the print settings available in the Page setup dialogue in different 

ways as discussed below. Page setup options include Page orientation, Page 

Size, Page Margins, etc. 

 The Print screen in Backstage View, displayed when you choose File » 

Print. 

 The Page Layout tab of the Ribbon. 
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Choosing Your Printer 

To switch to a different printer, choose File » Print and use the drop-down 

control in the Printer section to select any other installed printer. 
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Specifying What You Want to Print 

Sometimes you may want to print only a part of the worksheet rather than the 

entire active area. Choose File » Print and use the controls in the Settings 

section to specify what to print. 

 Active Sheets: Prints the active sheet or sheets that you selected. 

 Entire Workbook: Prints the entire workbook, including chart sheets. 

 Selection: Prints only the range that you selected before choosing File » 

Print. 
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Email Workbook 

MS Excel allows you to email the workbook very easily. To email the workbook 

to anyone, follow the below mentioned steps. 

 Choose File » Save and Send. It basically saves the document first and 

then the emails. 
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 Click on Send using E-mail if your email system is configured. MS Outlook 

will open with the file as attachment in the New Email Window. You can 

send mail this workbook to anyone with valid email address. 
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Translate Worksheet 

You can translate the text written in a different language, such as phrases or 

paragraphs, individual words (by using the Mini Translator), or translate your 

whole file with MS Excel 2010. 

Translation is available in the review tab of the ribbon in MS Excel 2010. You can 

quickly translate cell into different language with this option. 

Performing Translation Step By Step 

 Select the content, which you want to translate to a different language. 

 Choose review tab » translation. 

 It will open the pane from which you can select the language to which you 

need to translate. 

 You need to have an internet connection for performing translation. It will 

translate using the Microsoft Translator. 

 Click on Insert to apply translation changes. 
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Workbook Security 

We can apply security to the workbook by the concept of protection available in 

the Review Tab of ribbon. MS Excel's protection-related features fall into three 

categories. 

 Worksheet protection: Protecting a worksheet from being modified, or 

restricting the modifications to certain users. 

 Workbook protection: Protecting a workbook from having sheets 

inserted or deleted, and also requiring the use of password to open the 

workbook. 

Protect Worksheet 

You may want to protect a worksheet for a variety of reasons. One reason is to 

prevent yourself or others from accidentally deleting the formulas or other 

critical data. A common scenario is to protect a worksheet, so that the data can 

be changed, but the formulas can’t be changed. 

To protect a worksheet, choose Review » Changes group »Protect 

Sheet. Excel displays the Protect Sheet dialog box. Note that providing a 

password is optional. If you enter a password, that password will be required to 

unprotect the worksheet. You can select various options in which the sheet 

should be protected. Suppose we checked Format Cells option then Excel will not 

allow to format cells. 

 

62. Excel ─ Workbook Security 



Excel 2010 

152 

 

When somebody tries to format the cells, he or she will get the error as shown in 

the screenshot below. 

 

To unprotect a protected sheet, choose Review » Changes group » 

Unprotect Sheet. If the sheet was protected with a password, you’re prompted 

to enter that password. 

Protecting a Workbook 

Excel provides three ways to protect a workbook. 

 Requires a password to open the workbook. 

 Prevents the users from adding sheets, deleting sheets, hiding sheets, 

and unhiding sheets. 

 Prevents users from changing the size or position of windows. 
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Requiring a Password to Open a Workbook 

Excel lets you save a workbook with a password. After doing so, whoever tries to 

open the workbook, must enter the password. To add a password to a 

workbook, follow these steps. 

 Choose File » Info » Protect Workbook » Encrypt With Password. 

Excel displays the Encrypt Document dialog box. 

 Type a password and click OK. 

 Type the password again and click OK. 

 Save the workbook. 

 

To remove a password from a workbook, repeat the same procedure. In Step 2, 

however, delete the existing password symbols. 
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Protecting Workbook’s Structure and Windows 

To prevent others (or yourself) from performing certain actions in a workbook, 

you can protect the workbook’s structure and windows. When a workbook’s 

structure and windows are protected, the user may not Add a sheet, Delete a 

sheet, Hide a sheet, unhide a sheet, etc., and may not be allowed to change the 

size or position of a workbook’s windows respectively. 

To protect a worksheet’s structure and windows, follow the below mentioned 

steps. 

 Choose Review » Changes group » Protect Workbook to display the 

Protect Workbook dialog box. 

 In the Protect Workbook dialog box, select the Structure check box and 

Windows check box. 

 (Optional) Enter a password. 

 Click OK. 
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Data Tables 

In Excel, a Data Table is a way to see different results by altering an input cell in 

your formula. Data tables are available in Data Tab » What-If analysis 

dropdown » Data table in MS Excel. 

 

Data Table with Example 

Now, let us see data table concept with an example. Suppose you have the Price 

and quantity of many values. Also, you have the discount for that as third 

variable for calculating the Net Price. You can keep the Net Price value in the 

organized table format with the help of the data table. Your Price runs 

horizontally to the right while quantity runs vertically down. We are using a 

formula to calculate the Net Price as Price multiplied by Quantity minus total 

discount (Quantity * Discount for each quantity). 
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Now, for creation of data table, select the range of data table. Choose Data Tab 

» What-If analysis dropdown » Data table. It will give you dialogue asking 

for Input row and Input Column. Give the Input row as Price cell (In this case 

cell B3) and Input column as quantity cell (In this case cell B4). Please see the 

below screen-shot. 
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Clicking OK will generate data table as shown in the below screen-shot. It will 

generate the table formula. You can change the price horizontally or quantity 

vertically to see the change in the Net Price. 
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Pivot Tables 

A pivot table is essentially a dynamic summary report generated from a 

database. The database can reside in a worksheet (in the form of a table) or in 

an external data file. A pivot table can help transform endless rows and columns 

of numbers into a meaningful presentation of the data. Pivot tables are very 

powerful tool for summarized analysis of the data. 

Pivot tables are available under Insert tab » PivotTable dropdown » 

PivotTable. 

Pivot Table Example 

Now, let us see Pivot table with the help of example. Suppose you have huge 

data of voters and you want to see the summarized data of voter Information 

per party, then you can use the Pivot table for it. Choose Insert tab » Pivot 

Table to insert pivot table. MS Excel selects the data of the table. You can select 

the pivot table location as existing sheet or new sheet. 
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This will generate the Pivot table pane as shown below. You have various options 

available in the Pivot table pane. You can select fields for the generated pivot 

table. 

 

 Column labels: A field that has a column orientation in the pivot table. 

Each item in the field occupies a column. 

 Report Filter: You can set the filter for the report as year, then data gets 

filtered as per the year. 

 Row labels: A field that has a row orientation in the pivot table. Each 

item in the field occupies a row. 

 Values area: The cells in a pivot table that contain the summary data. 

Excel offers several ways to summarize the data (sum, average, count, 

and so on). 
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After giving input fields to the pivot table, it generates the pivot table with the 

data as shown below. 
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Charts 

A chart is a visual representation of numeric values. Charts (also known as 

graphs) have been an integral part of spreadsheets. Charts generated by early 

spreadsheet products were quite crude, but thy have improved significantly over 

the years. Excel provides you with the tools to create a wide variety of highly 

customizable charts. Displaying data in a well-conceived chart can make your 

numbers more understandable. Because a chart presents a picture, charts are 

particularly useful for summarizing a series of numbers and their 

interrelationships. 

Types of Charts 

There are various chart types available in MS Excel as shown in the below 

screen-shot. 

 

 Column: Column chart shows data changes over a period of time or 

illustrates comparisons among items. 

 Bar: A bar chart illustrates comparisons among individual items. 

 Pie: A pie chart shows the size of items that make up a data series, 

proportional to the sum of the items. It always shows only one data series 
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and is useful when you want to emphasize a significant element in the 

data. 

 Line: A line chart shows trends in data at equal intervals. 

 Area: An area chart emphasizes the magnitude of change over time. 

 X Y Scatter: An xy (scatter) chart shows the relationships among the 

numeric values in several data series, or plots two groups of numbers as 

one series of xy coordinates. 

 Stock: This chart type is most often used for stock price data, but can 

also be used for scientific data (for example, to indicate temperature 

changes). 

 Surface: A surface chart is useful when you want to find the optimum 

combinations between two sets of data. As in a topographic map, colors 

and patterns indicate areas that are in the same range of values. 

 Doughnut: Like a pie chart, a doughnut chart shows the relationship of 

parts to a whole; however, it can contain more than one data series. 

 Bubble: Data that is arranged in columns on a worksheet, so that x 

values are listed in the first column and corresponding y values and 

bubble size values are listed in adjacent columns, can be plotted in a 

bubble chart. 

 Radar: A radar chart compares the aggregate values of a number of data 

series. 
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Creating Chart 

To create charts for the data by below mentioned steps. 

 Select the data for which you want to create the chart. 

 Choose Insert Tab » Select the chart or click on the Chart group to 

see various chart types. 

 Select the chart of your choice and click OK to generate the chart. 
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Editing Chart 

You can edit the chart at any time after you have created it. 

 You can select the different data for chart input with Right click on chart 

» Select data. Selecting new data will generate the chart as per the new 

data, as shown in the below screen-shot. 

 

 You can change the X axis of the chart by giving different inputs to X-axis 

of chart. 

 You can change the Y axis of chart by giving different inputs to Y-axis of 

chart. 
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Pivot Charts 

A pivot chart is a graphical representation of a data summary, displayed in a 

pivot table. A pivot chart is always based on a pivot table. Although Excel lets 

you create a pivot table and a pivot chart at the same time, you can’t create a 

pivot chart without a pivot table. All Excel charting features are available in a 

pivot chart. 

Pivot charts are available under Insert tab » PivotTable dropdown » 

PivotChart. 

Pivot Chart Example 

Now, let us see Pivot table with the help of an example. Suppose you have huge 

data of voters and you want to see the summarized view of the data of voter 

Information per party in the form of charts, then you can use the Pivot chart for 

it. Choose Insert tab » Pivot Chart to insert the pivot table. 
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MS Excel selects the data of the table. You can select the pivot chart location as 

an existing sheet or a new sheet. Pivot chart depends on automatically created 

pivot table by the MS Excel. You can generate the pivot chart in the below 

screen-shot. 
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MS Excel Keyboard Short-cuts 

MS Excel offers many keyboard short-cuts. If you are familiar with windows 

operating system, you should be aware of most of them. Below is the list of all 

the major shortcut keys in Microsoft Excel. 

 Ctrl + A : Selects all contents of the worksheet. 

 Ctrl + B : Bold highlighted selection. 

 Ctrl + I : Italicizes the highlighted selection. 

 Ctrl + K : Inserts link. 

 Ctrl + U : Underlines the highlighted selection. 

 Ctrl + 1 : Changes the format of selected cells. 

 Ctrl + 5 : Strikethrough the highlighted selection. 

 Ctrl + P : Brings up the print dialog box to begin printing. 

 Ctrl + Z : Undo last action. 

 Ctrl + F3 : Opens Excel Name Manager. 

 Ctrl + F9: Minimizes the current window. 

 Ctrl + F10 : Maximizes the currently selected window. 

 Ctrl + F6 : Switches between open workbooks or windows. 

 Ctrl + Page up : Moves between Excel work sheets in the same Excel 

document. 

 Ctrl + Page down : Moves between Excel work sheets in the same Excel 

document. 

 Ctrl + Tab : Moves between Two or more open Excel files. 

 Alt + = : Creates a formula to sum all of the above cells 

 Ctrl + ' : Inserts the value of the above cell into cell currently selected. 

 Ctrl + Shift + ! : Formats the number in comma format. 

 Ctrl + Shift + $ : Formats the number in currency format. 

 Ctrl + Shift + # : Formats the number in date format. 

 Ctrl + Shift + % : Formats the number in percentage format. 
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 Ctrl + Shift + ^ : Formats the number in scientific format. 

 Ctrl + Shift + @ : Formats the number in time format. 

 Ctrl + Arrow key : Moves to the next section of text. 

 Ctrl + Space : Selects the entire column. 

 Shift + Space : Selects the entire row. 

 Ctrl + - : Deletes the selected column or row. 

 Ctrl + Shift + = : Inserts a new column or row. 

 Ctrl + Home : Moves to cell A1. 

 Ctrl + ~ : Switches between showing Excel formulas or their values in 

cells. 

 F2 : Edits the selected cell. 

 F3 : After a name has been created F3 will paste names. 

 F4 : Repeat last action. For example, if you changed the color of text in 

another cell pressing F4 will change the text in cell to the same color. 

 F5 : Goes to a specific cell. For example, C6. 

 F7 : Spell checks the selected text or document. 

 F11 : Creates chart from the selected data. 

 Ctrl + Shift + ; : Enters the current time. 

 Ctrl + ; : Enters the current date. 

 Alt + Shift + F1 : Inserts New Worksheet. 

 Alt + Enter : While typing text in a cell pressing Alt + Enter will move to 

the next line allowing for multiple lines of text in one cell. 

 Shift + F3 : Opens the Excel formula window. 

 Shift + F5 : Brings up the search box. 

 

 

 

 

 

 

 


